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The NAS stops responding to events when a lock time-out occurs in Microsoft Dynamics NAV


View products that this article applies to.

Microsoft Business Solutions-Navision and Microsoft Navision are now part of Microsoft Dynamics NAV. All references to Microsoft Business Solutions-Navision or to Microsoft Navision relate to Microsoft Dynamics NAV.

This article applies to Microsoft Dynamics NAV for all countries and all language locales.

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Symptoms

When a lock time-out occurs in Microsoft Dynamics NAV, the Microsoft Dynamics NAV Application Server (NAS) stops responding to events. Additionally, when the NAS receives the lock time-out, the NAS only processes every second message from the queue.

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Cause

This problem occurs because the NAS treats the lock time-out as a network error. Therefore, the NAS is not disconnected from the database before the NAS tries to reconnect to the database.

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Resolution

Hotfix information

A supported hotfix is now available from Microsoft. The hotfix corrects the problem that is described in this article. Apply the hotfix only to systems that are experiencing this specific problem.

To resolve this problem immediately, contact Technical Support for Microsoft Dynamics and related products to obtain the hotfix. You can log on to the Microsoft Dynamics site and create a new support request. To do this, visit the following Microsoft Web site: You can also contact Technical Support for Microsoft Dynamics and related products by telephone at (888) 477-7877.

Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Technical Support Professional for Microsoft Dynamics and related products determines that a specific update will resolve your problem. The usual support costs will apply to any additional support questions and issues that do not qualify for the specific update in question.


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Prerequisites

You must have Microsoft Dynamics NAV 4.0 Service Pack 3 with Update 6 installed to apply this hotfix.

How to obtain the Microsoft Dynamics NAV hotfix or update files

After you request a Microsoft Dynamics NAV hotfix or an update file from Technical Support for Microsoft Dynamics, a hyperlink will be sent to you in an e-mail.


The e-mail will contain a hyperlink and a password. You can use the hyperlink to download the Microsoft Dynamics NAV hotfix or the update files. When you click the hyperlink, the File Download – Security Warning dialog box opens. Then, you are prompted to run, to save, or to cancel the download.


If you click Run, the files start the download and the extraction process. You must specify a folder for the new files, and then provide the password.


If you click Save, you must specify a path for saving the compressed file. When you open the file that you saved, you are prompted to specify a path for the files. You must then provide the password provided in the e-mail.


If you click Cancel, the download process stops.

How to install a Microsoft Dynamics NAV hotfix or an update file

The Microsoft Dynamics NAV platform hotfixes and updates are made available as single files. To install a Microsoft Dynamics NAV hotfix or update, you must replace the existing Microsoft Dynamics NAV installation files with the hotfix or update files. To do this, follow these steps:
  1. Use the hotfix or the update files to replace the files in the Microsoft Dynamics NAV client installation that are listed in the following tables:

    Microsoft Dynamics NAV 2009

    File nameFile versionFile sizeDateTimePlatform
    Dbm.dll6.0.30233.0 444,23224-Nov-200917:09x86
    Fin.exe6.0.30233.0 12,257,09624-Nov-200917:09x86
    Finhlink.exe6.0.30233.0 452,43224-Nov-200917:09x86
    Finsql.exe6.0.30233.0 12,343,12024-Nov-200917:09x86
    Nc_netb.dll6.0.30233.0 108,36824-Nov-200917:09x86
    Nc_tcp.dll6.0.30233.0 108,36824-Nov-200917:09x86
    Nc_tcps.dll6.0.30233.0 153,42424-Nov-200917:09x86
    Ndbcs.dll6.0.30233.0 1,333,07224-Nov-200917:09x86
    Slave.exe6.0.30233.0 161,61624-Nov-200917:09x86

    Microsoft Dynamics NAV 2009 SP1

    File nameFile versionFile sizeDateTimePlatform
    Dbm.dll6.0.30232.0 427,84823-Nov-2009 23:16x86
    Fin.exe6.0.30232.0 12,598,60023-Nov-2009 23:17x86
    Finhlink.exe6.0.30232.0 452,43223-Nov-2009 23:17x86
    Finsql.exe6.0.30232.0 12,713,80823-Nov-2009 23:17x86
    Nc_netb.dll6.0.30232.0 96,59223-Nov-2009 23:16x86
    Nc_tcp.dll6.0.30232.0 98,64023-Nov-2009 23:17x86
    Nc_tcps.dll6.0.30232.0 141,13623-Nov-200923:16x86
    Ndbcs.dll6.0.30232.0 1,348,94423-Nov-200923:16x86
    Slave.exe6.0.30232.0 152,40023-Nov-200923:16x86

    Note Typically, the Microsoft Dynamics NAV client is installed in the following folder:
    C:\Program Files\Microsoft Business Solutions-Navision\Client\
    To replace the existing files, follow these steps:
    1. Close Microsoft Dynamics NAV.
    2. Locate the Microsoft Dynamics NAV client installation folder.
    3. Copy the files that you downloaded.
    4. Paste the files that you downloaded into the Microsoft Dynamics NAV client installation folder.
    5. In the Confirm File Replace dialog box, click Yes to overwrite the files in the installation folder.
  2. Replace the files in the Microsoft Dynamics NAV Application Server installation that are listed in the following table:

    Microsoft Dynamics NAV 2009

    File nameFile versionFile sizeDateTimePlatform
    Dbm.dll6.0.30233.0 444,23224-Nov-200902:13x86
    Nas.exe6.0.30233.0 2,082,63224-Nov-200902:13x86
    Nassql.exe6.0.30233.0 2,168,65624-Nov-200902:13x86
    Ndbcs.dll6.0.30233.0 1,333,07224-Nov-200902:13x86
    Slave.exe6.0.30233.0 161,61624-Nov-200902:13x86

    Microsoft Dynamics NAV 2009 SP1

    File nameFile versionFile sizeDateTimePlatform
    Dbm.dll6.0.30232.0 427,84823-Nov-200923:16x86
    Nas.exe6.0.30232.0 2,259,78423-Nov-200923:16x86
    Nassql.exe6.0.30232.0 2,352,46423-Nov-200923:16x86
    Ndbcs.dll6.0.30232.0 1,348,94423-Nov-200923:16x86
    Slave.exe6.0.30232.0 152,40023-Nov-200923:16x86

    To replace the files, follow these steps.
    1. Stop the Microsoft Dynamics NAV Application Server.
    2. Locate the Microsoft Dynamics NAV Application Server installation folder. Typically, the Microsoft Dynamics NAV Application Server is installed in the following folder:
      C:\Program Files\Microsoft Business Solutions-Navision\Application Server\
    3. Copy the files that you downloaded.
    4. Paste the files that you downloaded into the Microsoft Dynamics NAV Application Server installation folder.
    5. Click Yes to overwrite the files in the folder.
    6. Start the Microsoft Dynamics NAV Application Server.

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Status

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kb, kbmbsdatabaseandplatforms, kbmbspartner, kbmbsmigrate, kbnavision40presp4fix, kbqfe, kbhotfixserver, kbautohotfix

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Article Info
Article ID : 948302
Revision : 2
Created on : 1/31/2017
Published on : 1/31/2017
Exists online : False
Views : 265