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Event ID 10 may be logged on a computer that is running a clean installation of Windows Vista SP1 or Windows Server 2008


View products that this article applies to.

Support for Windows Vista Service Pack 1 (SP1) ends on July 12, 2011. To continue receiving security updates for Windows, make sure you're running Windows Vista with Service Pack 2 (SP2). For more information, refer to this Microsoft web page: Support is ending for some versions of Windows.

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Symptoms

On a computer that is running a clean installation of Windows Vista Service Pack 1 (SP1) or Windows Server 2008, an event that resembles the following event may be logged in the System log: Note This event is logged every time that you shut down and then restart the operating system.

This problem occurs if the Virtual Disk service is started.

Note The Virtual Disk service is a "demand start" service that runs only if something has called it to be run. Therefore, the start type of the Virtual Disk service in Services.msc is "MANUAL."

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Cause

This issue occurs because the Virtual Disk service stops the Virtual Disk providers when it shuts down. When this occurs, the Virtual Disk service unregisters for driver notifications. Then, the service stops the notification processing thread.

Because the process occurs in this order, the notification processing thread may call back in to the driver after the provider has unregistered for notifications with the driver. In this case, an event is logged.

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Resolution

To resolve this issue if you have an application, an accessory, or a service that experiences a failed Virtual Disk start, restart the Virtual Disk service. To do this, follow these steps:
  1. Click Start, type cmd in the Start Search box, right-click Cmd.exe, click Run as administrator, and then click Continue.
  2. Type the following command, and then press ENTER:
    Net Stop "Virtual Disk"
  3. Type the following command, and then press ENTER:
    Net Start "Virtual Disk"
Note Even if the Virtual Disk service has been restarted once, the issue may still occur after you restart the operating system.

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Keywords: kb, kbexpertiseadvanced, kbtshoot, kbprb

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Article Info
Article ID : 948275
Revision : 1
Created on : 1/7/2017
Published on : 6/21/2014
Exists online : False
Views : 314