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FIX: BizTalk Server host instance stops unexpectedly and restarts because of a System.OutOfMemoryException exception in BizTalk Server


View products that this article applies to.

Symptoms

When you use the Rule Engine Update service in Microsoft BizTalk Server 2006 or Microsoft BizTalk Server 2006 R2, the BizTalk Server host instance stops unexpectedly and restarts. Additionally, a warning message is logged in application event log that resembles the following:

Event Type: Warning
Event Source: BizTalk Server 2006
Event Category: BizTalk Server 2006
Event ID: 5410
Description: An error occurred that requires the BizTalk service to stop. The most common causes are the following:

  1. An unexpected out of memory error.

    OR
  2. An inability to connect or a loss of connectivity to one of the BizTalk databases.
The service will shutdown and auto-restart in 1 minute. If the problematic database remains unavailable, this cycle will repeat.

Error message: Exception of type 'System.OutOfMemoryException' was thrown.
Error source: mscorlib
BizTalk host name: ProcessHost
Windows service name: BTSSvc$ProcessHost

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Cause

This problem occurs because of an error in the Business Rule Engine that causes a memory leak.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: - Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have BizTalk Server 2006 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, you must restart the BizTalk host instance service after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Microsoft BizTalk Server 2006
File nameFile versionFile sizeDateTimePlatform
Microsoft.ruleengine.dll3.5.1753.0971,80012-Mar-200821:08x86


Note If you are using BizTalk Server 2006 R2, you can apply BizTalk Server 2006 R2 Service Pack 1 to resolve this problem.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: KB948238, kbqfe, kbsurveynew, kbbiztalk2006presp1fix, kbfix, kbexpertiseadvanced, kbbtsadmin, kbautohotfix

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Article Info
Article ID : 948238
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 503