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A kernel driver cannot be unloaded on a Windows Server 2003-based computer when the Service Control Manager (SCM) incorrectly increases a reference count


View products that this article applies to.

Symptoms

Consider the following scenario.
  • On a Windows Server 2003-based computer, a user-mode process loads a virus engine kernel driver by using the Service Control Manager (SCM).
  • Then, the DriverEntry function is called. This operation may take as long as one minute if the operation loads large amounts of engine data.
  • You run the Sc.exe utility to query the status of the virus engine kernel driver when the DriverEntry function is running.
In this scenario, you cannot unload the kernel driver.

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Cause

This problem occurs because the SCM incorrectly increases a reference count by 1.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 installed.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with SP1, x86-based versions
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File nameFile versionFile sizeDateTimePlatform
Services.exe5.2.3790.3083110,08031-Jan-200816:43x86
Windows Server 2003 with SP2, x86-based versions
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File nameFile versionFile sizeDateTimePlatform
Services.exe5.2.3790.4228111,10431-Jan-200811:03x86
Windows Server 2003 with SP1, IA64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Services.exe5.2.3790.3083306,68801-Feb-200803:29IA-64
Windows Server 2003 with SP2, IA64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Services.exe5.2.3790.4228307,71201-Feb-200803:36IA-64
Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Services.exe5.2.3790.3083221,69601-Feb-200803:29x64
Windows Server 2003 with SP2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Services.exe5.2.3790.4228224,76801-Feb-200803:37x64

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Workaround

To work around this problem, restart the computer. Then, the driver can be successfully deleted. However, you may be unable to restart the server if important services or applications are running when this problem occurs.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbpubtypekc, kbqfe, kbhotfixserver, KB948234

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Article Info
Article ID : 948234
Revision : 3
Created on : 2/18/2008
Published on : 2/18/2008
Exists online : False
Views : 208