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An application that calls the GetThreadContext function may stop responding on a computer that is running an Itanium-based version of Windows Server 2003


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You are running an Itanium-based version of Windows Server 2003.
  • An application on the computer calls the GetThreadContext function.
In this scenario, the application may stop responding. For example, a Java virtual machine and related Java applications may stop responding after the Java virtual machine calls GetThreadContext function.

This problem is likely to occur when the system is under a heavy load. If you debug the application, the debugging results may indicate that the call to the GetThreadContext function is not returned.

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Cause

This problem may occur because of a bug in the asynchronous procedure call (APC) routing module on Windows Server 2003 Itanium-based systems. APCs are not correctly routed to threads.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 installed. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdll.dll5.2.3790.30771,636,35224-Jan-200803:42IA-64SP1Not Applicable
Ntkrnlmp.exe5.2.3790.30776,534,65624-Jan-200803:42IA-64SP1Not Applicable
Wntdll.dll5.2.3790.3077765,95224-Jan-200803:42x86SP1WOW
Windows Server 2003 with Service Pack 2, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdll.dll5.2.3790.42231,636,86424-Jan-200803:48IA-64SP2Not Applicable
Ntkrnlmp.exe5.2.3790.42236,568,96024-Jan-200803:48IA-64SP2Not Applicable
Wntdll.dll5.2.3790.4223766,46424-Jan-200803:48x86SP2WOW

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: KB947504, kbqfe, kbhotfixserver, kbfix, kbbug, kbwinserv2003postsp2fix, kbexpertiseinter, kbexpertiseadvanced, kbautohotfix

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Article Info
Article ID : 947504
Revision : 3
Created on : 2/7/2008
Published on : 2/7/2008
Exists online : False
Views : 213