Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The Wmiprvse.exe process crashes on an Exchange Server 2003 server


View products that this article applies to.

Symptoms

The Wmiprvse.exe process crashes on an Exchange Server 2003 server. Additionally, the following error is logged in the Application log:

Event Type: Error
Event Source: Application Error
Event Category: (100)
Event ID: 1000
Description:
Faulting application wmiprvse.exe, version <version number>, faulting module dsaccess.dll, version <version number>, fault address <address>.

↑ Back to the top


Cause

This issue occurs because a thread tries to destroy a data object that is being used by another thread.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

This hotfix requires Microsoft Exchange Server 2003 Service Pack 2 to be installed on the server because of file dependencies. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993� How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You have to restart the computer after you apply this hotfix if the wmiprvse.exe process is running on the computer.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Dsaccess.dll6.5.7653.28647,68022-Feb-200802:30
Dscmsg.dll6.5.7653.28330,24021-Feb-200817:48

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

When this issue occurs, the following call stack is generated.
Thread A is destroying the data:
hildEBP RetAddr  Args to Child              
067ef2e4 7c821364 77e42439 00000000 067ef328 ntdll!KiFastSystemCallRet 
067ef2e8 77e42439 00000000 067ef328 62eeb02c ntdll!NtDelayExecution+0xc
067ef350 77e424b7 000003e8 00000000 067ef384 kernel32!SleepEx+0x68 
067ef360 62eb3252 000003e8 621b34dc 00000000 kernel32!Sleep+0xf
067ef384 6215abfa 00000000 03040750 00000000 dsaccess!TerminateDs+0x24e 
067ef398 621990b7 00000000 03040750 00000000 reapi!RedsDeinitialize+0xe9
067ef3b4 6219345b 621945a9 03040750 067ef3d8 reapi!CDistributedMonitor::FinalRelease+0x23 

While Thread A is using it:
hildEBP RetAddr  Args to Child              
061a9614 7c822124 77e6baa8 0000055c 00000000 ntdll!KiFastSystemCallRet 
061a9618 77e6baa8 0000055c 00000000 061a965c ntdll!NtWaitForSingleObject+0xc
061a9688 77e6ba12 0000055c 00009c40 00000000 kernel32!WaitForSingleObjectEx+0xac
061a969c 009f4ff9 0000055c 00009c40 00000000 kernel32!WaitForSingleObject+0x12 
061aa4dc 009f58f3 007c0f60 061aa7b0 00000000 exwmi!CBaseFrame::LExceptionFilter+0x581
061aa4f0 6304219c 061aa7b0 061aa7b0 00000004 exwmi!CBaseFrame::LUnhandledExceptionFilterStatic+0x42
061aa50c 77e995f7 061aa7b0 c0000005 007e4180 pttrace!TopLevelExceptionFilter+0x8a 
061aa764 77bc3e74 061aa7b0 00000000 00000000 kernel32!UnhandledExceptionFilter+0xac 
061aa784 77bcb547 c0000005 061aa7b0 77bc6cd5 msvcrt!_XcptFilter+0x178
061aa790 77bc6cd5 061aa7b8 00000000 061aa7b8 msvcrt!_threadstartex+0x8b 
061aa7b8 7c82eeb2 061aa89c 061bffa8 061aa8b8 msvcrt!_except_handler3+0x61 
061aa7dc 7c82ee84 061aa89c 061bffa8 061aa8b8 ntdll!ExecuteHandler2+0x26 
061aa884 7c82ecc6 061a8000 061aa8b8 061aa89c ntdll!ExecuteHandler+0x24 
061aa884 7c82f350 061a8000 061aa8b8 061aa89c ntdll!KiUserExceptionDispatcher+0xe 
061aab90 62ea6e27 00000018 00000018 62ea6e74 ntdll!RtlEnterCriticalSection+0x19 
061aab9c 62ea6e74 00000018 62ea712b 02064ce8 dsaccess!CMRWLock::EnterPromote+0xa 
061aaba4 62ea712b 02064ce8 62ea7148 00000004 dsaccess!CMRWLock::EnterWrite+0x8 
061aabb8 62ea71f8 00000004 02064ce8 62ea71c3 dsaccess!CReqCache::DeleteReqFromContext+0x23 
061aabc4 62ea71c3 02064ce8 061bff84 62e820fd dsaccess!CDSContext::~CDSContext+0x4e 
061aabd0 62e820fd 00000001 00000000 00000000 dsaccess!CDSContext::`scalar deleting destructor'+0xb
061aabe0 62eb04d6 00000000 007e4180 007e4bd8 dsaccess!CDSContext::Release+0x1e 
061bff84 77bcb530 00000001 00000000 00000000 dsaccess!CDSContext::ListPollThread+0x69c 
061bffb8 77e66063 007e4bd8 00000000 00000000 msvcrt!_threadstartex+0x74 
061bffec 00000000 77bcb4bc 007e4bd8 00000000 kernel32!BaseThreadStart+0x34

↑ Back to the top


Keywords: KB947485, kbsurveynew, kbautohotfix, kbexchstore, kbqfe, kbhotfixserver

↑ Back to the top

Article Info
Article ID : 947485
Revision : 1
Created on : 2/6/2009
Published on : 2/6/2009
Exists online : False
Views : 288