Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

When TrendMicro OfficeScan is installed on a Windows Server 2003-based computer, event ID 2020 occurs, and the computer may stop responding, or the computer may respond slowly


View products that this article applies to.

Symptoms

When TrendMicro OfficeScan is installed on a Windows Server 2003-based computer, event ID 2020 occurs, and the computer may stop responding. Or, the computer may respond slowly. Additionally, the Vmem tag uses from 50 MB through 100 MB of paged pool memory.

↑ Back to the top


Cause

The Vmem tag belongs to the Scan Engine that TrendMicro provides.

↑ Back to the top


Resolution

To resolve this problem, contact TrendMicro. For more information about how to do this, see the "More information" section.

↑ Back to the top


Workaround

To work around this problem, use the following methods to make the kernel paged pool larger, as appropriate for your situation.

Method 1: On Windows Server 2003 x86-based computers that do not use the /3GB switch

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

Locate the following registry subkey:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Memory Management
Then, make sure that the value data of two registry entries under this subkey have the following configuration:

Value name: PagedPoolSize
Data type: REG_DWORD
Base: Hexadecimal
Value data: 0xFFFFFFFF

Value name: PoolUsageMaximum
Data type: REG_DWORD
Base: Hexadecimal
Value data: 1E

Method 2: On Windows Server 2003 x86-based computers that use the /3GB switch

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

Locate the following registry subkey:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Memory Management
Then, make sure that the value data of two registry entries under this subkey have following configuration:

Value name: PagedPoolSize
Data type: REG_DWORD
Base: Hexadecimal
Value data: 0x0d800000

Note The 0x0d800000 value data for the PagedPoolSize registry entry is conservative. You can increase the value to 0x11800000. However, do not set the value to FFFFFFFF. On versions of Windows Server 2003 SP1 or SP2 that use the/3GB switch, the FFFFFFFF value is ignored.

Value name: PoolUsageMaximum
Data type: REG_DWORD
Base: Hexadecimal
Value data: 1E

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about kernel mode memory usage, visit the following Web site: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

↑ Back to the top


Keywords: KB947475, kbprb, kbtshoot, kbexpertiseinter

↑ Back to the top

Article Info
Article ID : 947475
Revision : 1
Created on : 2/18/2008
Published on : 2/18/2008
Exists online : False
Views : 303