Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Windows Server 2003 does not set the value of the icmp6_cksum field in the icmp6_hdr structure for ICMPv6 packets


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You use the socket function to create an ICMPv6 raw socket in Windows Server 2003.
  • You build an ICMP header. Additionally, you set the value of icmp6_cksum to 0.
  • You use the API sendto function to send the created package.
In this scenario, the value of the icmp6_cksum field in the icmp6_hdr structure is still 0 in the transmitted packet. This behavior does not comply with the RFC 3542 requirements. This behavior causes the functions of some applications to fail if the following conditions are true:
  • The application uses the ICMPv6 protocol.
  • The application expects Windows Server 2003 to set the value of the icmp6_cksum field.

↑ Back to the top


Cause

Windows Server 2003 does not comply with the RFC 3542 requirements to set the value of the icmp6_cksum field.

↑ Back to the top


Resolution

Hotfix information for Windows Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Windows Server 2003 Service Pack 1 (SP1) or Windows Server 2003 Service Pack 2 (SP2) must be installed before you apply this hotfix. For more information about the latest service pack for Windows Server 2003, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
6to4svc.dll5.2.3790.277199,84016-Aug-200614:01x86SP1
Tcpip6.sys5.2.3790.3068225,92009-Jan-200810:02Not applicableSP1
Windows Server 2003 with Service Pack 2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Tcpip6.sys5.2.3790.4215234,49609-Jan-200810:35Not applicableSP2SP2QFE
Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
6to4svc.dll5.2.3790.2771124,41610-Jan-200805:46x64SP1Not applicable
Tcpip6.sys5.2.3790.3068362,49610-Jan-200805:46x64SP1Not applicable
W6to4svc.dll5.2.3790.277199,84010-Jan-200805:46x86SP1WOW
Windows Server 2003 with Service Pack 2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Tcpip6.sys5.2.3790.4215375,68010-Jan-200806:26x64SP2SP2QFE
Windows Server 2003 with Service Pack 1, IA-64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
6to4svc.dll5.2.3790.2771362,49610-Jan-200805:46IA-64SP1Not applicable
Tcpip6.sys5.2.3790.3068736,76810-Jan-200805:46Not applicableSP1Not applicable
W6to4svc.dll5.2.3790.277199,84010-Jan-200805:46x86SP1WOW
Windows Server 2003 with Service Pack 2, IA-64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Tcpip6.sys5.2.3790.4215764,41610-Jan-200806:13Not applicableSP2SP2QFE

Hotfix information for Windows XP

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Windows XP Service Pack 1 (SP1) or Windows XP Service Pack 2 (SP2) must be installed before you apply this hotfix. For more information about the latest service pack for Windows XP, click the following article number to view the article in the Microsoft Knowledge Base:
322389� How to obtain the latest Windows XP service pack

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP Professional x64 Edition with SP1, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
6to4svc.dll5.2.3790.2771124,41610-Jan-200805:46x64SP1Not applicable
Tcpip6.sys5.2.3790.3068362,49610-Jan-200805:46x64SP1Not applicable
W6to4svc.dll5.2.3790.277199,84010-Jan-200805:46x86SP1WOW
Windows XP Professional x64 Edition with SP2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Tcpip6.sys5.2.3790.4215375,68010-Jan-200806:26x64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about RFC 3542, visit the following Internet FAQ Archives Web site:

↑ Back to the top


Keywords: kbautohotfix, kbexpertiseinter, kbhotfixserver, kbqfe, KB947369

↑ Back to the top

Article Info
Article ID : 947369
Revision : 3
Created on : 1/24/2008
Published on : 1/24/2008
Exists online : False
Views : 337