Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The wireless network connection appears to be disabled, and you receive a message in Windows Server 2008: "Windows tried a repair but a problem still exists"


View products that this article applies to.

Beta Information
This article discusses a beta release of a Microsoft product. The information in this article is provided as-is and is subject to change without notice.

No formal product support is available from Microsoft for this beta product. For information about how to obtain support for a beta release, see the documentation that is included with the beta product files, or check the Web location where you downloaded the release.

↑ Back to the top


Symptoms

Consider the following scenario. You have a computer that is running Windows Server 2008 and that has a wireless network adapter installed. The Wireless LAN Service feature is not installed. In this scenario, you may experience the following symptoms:
  • In the Network Connections configuration dialog box, the status of the wireless network connection is "disabled." If you right-click the wireless network connection icon and then click Enable, the Wireless Network Connection dialog box appears and indicates that the connection has been enabled. However, in the Network Connections dialog box, the wireless network connection still appears to be disabled.

    Note In Device Manager, the status of the wireless adapter driver is "enabled."
  • In the Network Connections dialog box, you right-click the wireless network connection icon and then click Diagnose. When you do this, you receive the following message:
    Windows tried a repair but a problem still exists. The network adapter "Wireless Network Connection" is not correctly configured to use the IP protocol. The network adapter device name is experiencing driver or hardware related issues. Make sure your Internet Protocol Bindings are correct.
    Note This message does not indicate the actual cause of the issue. In Device Manager, you can see that the wireless adapter runs correctly. Additionally, if you view the properties of the network adapter, you see that all the protocols are correctly bound to the network adapter.

↑ Back to the top


Cause

This issue occurs because the Wireless LAN Service feature is not installed.

↑ Back to the top


Resolution

To resolve this issue, follow these steps:
  1. Click Start, type server manager in the Start Search box, and then click Server Manager in the Programs list.

    If you are prompted for an administrator password or for confirmation, type your password, or click Continue.
  2. In Server Manager, click Features.
  3. In the Features pane, click Add Features.
  4. In the Add Features Wizard, click Wireless LAN Service, and then click Next.
  5. Click Install.
  6. After the installation process is complete, click Close.

↑ Back to the top


More information

For more information about Windows Server 2008, visit the following Microsoft Web site:

↑ Back to the top


Keywords: KB947307, kbprb, kbtshoot, kbexpertiseinter

↑ Back to the top

Article Info
Article ID : 947307
Revision : 2
Created on : 2/6/2008
Published on : 2/6/2008
Exists online : False
Views : 318