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Error message when you open the Disk Management MMC snap-in in Windows Server 2003 with SP1 after you uninstall Veritas Volume Manager: "Unable to connect to Logical Disk Management Service"


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a server is running Windows Server 2003 with Service Pack 1 (SP1).
  • Veritas Volume Manager is running on this server.
  • You connect the server to a Storage Area Network (SAN).
  • You uninstall Veritas Volume Manager.
  • You open the Disk Management Microsoft Management Console (MMC) snap-in.
In this scenario, you receive the following error message:
Unable to connect to Logical Disk Management Service.
When this problem occurs, the following events are logged in the System log.

Event 1

Event Type: Error
Event Source: Virtual Disk Service
Event Category: None
Event ID: 17
Date: Date
Time: Time
User: N/A
Computer: ComputerName
Description: The description for Event ID (17) in Source (Virtual Disk Service) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event:
{F96544E6-5C8D-47B9-AA6E-FD19AB278629}, 8007007E@02000011.

Event 2

Event Type: Information
Event Source: Service Control Manager
Event Category: None
Event ID: 7036
Date: Date
Time: Time
User: N/A
Computer: ComputerName
Description: The Virtual Disk Service service entered the stopped state.

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Cause

This problem occurs because the registration of the Disk Management MMC snap-in is corrupted when you uninstall Veritas Volume Manager.

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Workaround

To work around this problem, follow these steps:
  1. Restore the default permissions to the %Windir%\Registration folder. To do this, follow the steps that are mentioned in Microsoft Knowledge Base article 909444. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
    909444 You may experience various problems after you install the Microsoft Security Bulletin MS05-051 for COM+ and MS DTC
  2. Enable the DMBoot service. To do this, follow these steps:
    1. Click Start, click Run, type Regedit, and then click OK.
    2. Locate the following registry subkey:
      HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\dmboot
    3. Double-click the Start registry entry.
    4. In the Edit DWORD Value dialog box, type 0 in the Value data box.
  3. Extract the Windows Server 2003 SP1 package.
  4. In the i386 folder, right-click the Dmreg.inf file, and then click Install.
  5. Restart the server.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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References

To download Windows Server 2003 SP1, visit the following Microsoft download Web site: The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

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Keywords: kberrmsg, kbexpertiseadvanced, kbtshoot, kbprb, KB947306

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Article Info
Article ID : 947306
Revision : 2
Created on : 2/5/2008
Published on : 2/5/2008
Exists online : False
Views : 276