Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

After a COM application handles an access violation on a Windows Server 2003-based computer or on a Windows XP-based computer, the COM application stops responding


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You are running a Windows Server 2003-based computer or a Windows XP-based computer.
  • A COM application that is running on the computer handles an access violation.
In this scenario, the COM application stops responding (hangs).

↑ Back to the top


Cause

This issue occurs if the stored state in the global interface table (GIT) becomes corrupted during a GIT operation after a COM application handles an access violation. When the stored state becomes corrupted, the COM application catches the access violation, and then the COM application runs sequentially. However, the corrupted state in the GIT causes later GIT operations to stop responding. Therefore, the COM application also stops responding.

↑ Back to the top


Resolution

Hotfix information for Windows Server2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

This hotfix requires Windows Server 2003 Service Pack 2 (SP2) to be installed.
889100� How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 2, x86 version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ole32.dll5.2.3790.42191,267,20017-Jan-200805:39x86SP2SP2QFE
Windows Server 2003 with Service Pack 2, x64 version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ole32.dll5.2.3790.42192,623,48817-Jan-200804:39x64SP2SP2QFE
Wole32.dll5.2.3790.42191,267,20017-Jan-200804:39x86SP2WOW
Windows Server 2003 with Service Pack 2, IA 64 version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ole32.dll5.2.3790.42194,098,04817-Jan-200804:34IA-64SP2SP2QFE
Wole32.dll5.2.3790.42191,267,20017-Jan-200804:34x86SP2WOW

Hotfix information for Windows XP Professional x64 Edition with SP2

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

This hotfix requires Windows Server 2003 Service Pack 2 (SP2) to be installed.
889100� How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP Professional x64 Edition with SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ole32.dll5.2.3790.42192,623,48817-Jan-200804:39x64SP2SP2QFE
Wole32.dll5.2.3790.42191,267,20017-Jan-200804:39x86SP2WOW

Hotfix information for Windows XP

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

This hotfix requires Windows XP Professional x64 Edition Service Pack 2 to be installed.
322389 � How to obtain the latest Windows XP service pack

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP with SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ole32.dll5.1.2600.34171,287,16825-Jul-200813:03x86
Windows XP with SP3
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ole32.dll5.1.2600.56481,287,68025-Jul-200812:51x86

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: kbautohotfix, kbexpertiseinter, kbhotfixserver, kbqfe, KB947100

↑ Back to the top

Article Info
Article ID : 947100
Revision : 3
Created on : 8/4/2008
Published on : 8/4/2008
Exists online : False
Views : 357