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Error “Client found response content type of 'text/html; charset=utf-8', but expected 'text/xml'.” occurs when you try to install Microsoft Dynamics CRM 4.0 or print reports in Microsoft Dynamics CRM 4.0


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Symptoms

When you try to install Microsoft Dynamics CRM 4.0, you specify the name of an existing server that is running Microsoft SQL Server Reporting Services (the report server). If the name of the report server contains extended ASCII characters, you receive the following error message in the Environment Diagnostics Wizard:
Failure: T\'çÒãÚİŠètµp ƒåìlëd tõ vålìdàtè şpê¢íƒìèd Rëpõrtïñğ Şêrvî¢èš Rêpòrt Šêrvër http://server_name/reportserver.

Èrrør: Client found response content type of 'text/html; charset=utf-8', but expected 'text/xml'.

The request failed with the error message:
--
<?xml version="1.0" ?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" >
<head>
<title>Server Unavailable </title>
</head>
<body>
<h1><span style="font-family:Verdana;color: #ff3300">Server Application Unavailable </span></h1>
<p>
<span style="font-family:Verdana;"> The Web application you are attempting to access on this web server is currently unavailable. Please hit the "Refresh" button in your web browser to retry your request. </span></p>
<p>
<b>Administrator Note: </b> An error message detailing the cause of this specific request failure can be found in the application event log of the web server. Please review this log entry to discover what caused this error to occur.
</p>
</body>
</html>
--
When you run the reports in Microsoft Dynamics CRM 4.0, you get the following error message:
Client found response content type of 'text/html; charset=utf-8', but expected 'text/xml'. The request failed with the error message: -- <html> <head> <title> SQL Server Reporting Services </title><meta name="Generator" content="Microsoft SQL Server Reporting Services 9.00.3042.00" /> <meta name="HTTP Status" content="500" /> <meta name="ProductLocaleID" content="9" /> <meta name="CountryLocaleID" content="1033" /> <meta name="StackTrace" content /> <style> BODY {FONT…….

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Cause

This can be caused by one of the following:
  • The name of an existing report server contains extended ASCII characters.
  • The problem occurs if you rename the "Reports" and " ReportServer" virtual directories.

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Resolution

Report server contains extended ASCII characters

To resolve this problem, use one of the following methods.

Method 1: Rename the report server

Rename the report server by using a name that does not contain extended ASCII characters. A name is a text string of up to 24 characters that contains any of the following characters:
  • Alphabet (A-Z)
  • Digits (0-9)
  • Minus sign (-)
  • Period (.)

Method 2: Use an alias for the report server

Specify the alias of the existing report server when you install Microsoft Dynamics CRM 4.0.

"Reports" and " ReportServer" virtual directories were renamed

To resolve this problem follow these steps:
  1. On the Microsoft CRM server, click Start, point to All Programs, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.
  2. Delete the “Reports” and the “Reportserver” virtual directories from IIS.
  3. Use Reporting Services Configuration Manager to recreate the virtual directories. Make sure to use the following names: “Reports” and “Reportserver”.
  4. Change SRS URL in CRM Deployment Manager by disabling the Organization and then editing the Organization.
  5. After making the above changes, restart IIS, SQL service & SQL Reporting Service.
  6. Make sure that CRM uses the new virtual directories. To do this check the following:
    • In the registry on the CRM Server, verify the key:
      HKEYLOCALMACHINE\SOFTWARE\MICROSOFT\MSCRM
    • In MSCRM_CONFIG: dbo.Organization table, verify the SrsUrl is pointing to the correct URL.
  7. Open a new browser and run default reports through CRM, reports will render successfully.

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Keywords: kbsetup, kbinstallation, kberrmsg, kbtshoot, kbmbsmigrate, kbprb, kbexpertiseinter, KB946788

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Article Info
Article ID : 946788
Revision : 2
Created on : 6/18/2009
Published on : 6/18/2009
Exists online : False
Views : 8