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When you use a third-party tool to open a picture that was previously edited in Windows Photo Gallery, some metadata fields are duplicated, dropped, or corrupted


View products that this article applies to.

Symptoms

In Windows Photo Gallery, you add some metadata to a picture file. When you open this picture in a third-party tool, some metadata fields for the picture file may be duplicated, dropped, or corrupted.

This issue occurs in Windows XP, in Windows Vista, and in Windows Server 2008.

For example, you open and save a .jpg picture in Windows Photo Gallery, and then you embed some metadata into the picture by using a third-party application. When you open this picture in Adobe Photoshop, you receive an error.

In this example, if you open the .jpg file in a hexadecimal editor, you see duplicated XMP metadata tags. One metadata tag is set to xmp:xmpmeta and the other one is set to x:xmpmeta.

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Cause

In Windows XP, in Windows Vista, and in Windows Server 2008, the Windows Imaging Component uses the xmp:xmpmeta tag. However, some third-party tools may recognize only the x:xmpmeta tag.

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Resolution

A hotfix is available to resolve this issue. After you apply this hotfix, the Windows Imaging Component uses the x:xmpmeta tag instead of the xmp:xmpmeta tag. This change affects applications that rely on the Windows Imaging Component, such as Windows Photo Gallery and Windows Live Photo Gallery.

Hotfix information for Windows XP

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 2 or Windows XP Service Pack 3 installed on the computer.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Wicext.dll6.0.6001.22133347,13628-Apr-200813:58x86

Hotfix information for Windows Vista and for Windows Server 2008

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are no prerequisites.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista and Windows Server 2008, 32-bit editions
File nameFile versionFile sizeDateTimePlatform
Package_1_for_kb946666~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,95011-Mar-200821:57Not Applicable
Package_2_for_kb946666~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,78811-Mar-200821:57Not Applicable
Package_3_for_kb946666~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,78811-Mar-200821:57Not Applicable
Package_for_kb946666_client_0~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,42511-Mar-200821:57Not Applicable
Package_for_kb946666_client_1~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,36711-Mar-200821:57Not Applicable
Package_for_kb946666_client~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,71111-Mar-200821:57Not Applicable
Package_for_kb946666_server_0~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,42511-Mar-200821:57Not Applicable
Package_for_kb946666_server~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,43011-Mar-200821:57Not Applicable
Update.mumNot Applicable2,08411-Mar-200821:57Not Applicable
X86_6b4cb25b7076eda2ef1237dade41afaf_31bf3856ad364e35_6.0.6001.22133_none_e259a122b5291b12.manifestNot Applicable70311-Mar-200821:57Not Applicable
X86_be8707f4b9a83fa066893c21bb6cb66b_31bf3856ad364e35_6.0.6000.20788_none_15464dee6b89199c.manifestNot Applicable70311-Mar-200821:57Not Applicable
X86_microsoft-windows-windowscodecext_31bf3856ad364e35_6.0.6000.20788_none_91e6ad81d4d6337b.manifestNot Applicable320,63708-Mar-200804:49Not Applicable
X86_microsoft-windows-windowscodecext_31bf3856ad364e35_6.0.6001.22133_none_93fdfa51d1d8ba04.manifestNot Applicable320,64911-Mar-200803:50Not Applicable
Windowscodecsext.dll6.0.6000.20788347,13608-Mar-200804:20x86
Windowscodecsext.dll6.0.6001.22133347,13611-Mar-200803:18x86
Windows Vista and Windows Server 2008, 64-bit editions
File nameFile versionFile sizeDateTimePlatform
Amd64_72e62fec29004421655e527362b2f5fb_31bf3856ad364e35_6.0.6000.20788_none_8414b5b4211e9ee1.manifestNot Applicable1,05411-Mar-200821:57Not Applicable
Amd64_982b2ca88bbf1b958da2de5671436bc8_31bf3856ad364e35_6.0.6001.22133_none_6dca824d6bf89b28.manifestNot Applicable1,05411-Mar-200821:57Not Applicable
Amd64_microsoft-windows-windowscodecext_31bf3856ad364e35_6.0.6000.20788_none_ee0549058d33a4b1.manifestNot Applicable320,66708-Mar-200805:00Not Applicable
Amd64_microsoft-windows-windowscodecext_31bf3856ad364e35_6.0.6001.22133_none_f01c95d58a362b3a.manifestNot Applicable320,67911-Mar-200804:27Not Applicable
Package_1_for_kb946666~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable2,18311-Mar-200821:57Not Applicable
Package_2_for_kb946666~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable2,01911-Mar-200821:57Not Applicable
Package_3_for_kb946666~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable2,01911-Mar-200821:57Not Applicable
Package_for_kb946666_client_0~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,43311-Mar-200821:57Not Applicable
Package_for_kb946666_client_1~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,37511-Mar-200821:57Not Applicable
Package_for_kb946666_client~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,72111-Mar-200821:57Not Applicable
Package_for_kb946666_server_0~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,43311-Mar-200821:57Not Applicable
Package_for_kb946666_server~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,43811-Mar-200821:57Not Applicable
Update.mumNot Applicable2,09811-Mar-200821:57Not Applicable
Windowscodecsext.dll6.0.6000.20788387,07208-Mar-200804:28x64
Windowscodecsext.dll6.0.6001.22133387,07211-Mar-200803:51x64
Windows Vista and Windows Server 2008, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Ia64_3eabb1fed70e309acacbe91c258d82eb_31bf3856ad364e35_6.0.6001.22133_none_7bdb9c60621a248a.manifestNot Applicable1,05211-Mar-200821:57Not Applicable
Ia64_microsoft-windows-windowscodecext_31bf3856ad364e35_6.0.6001.22133_none_93ff9e47d1d6c300.manifestNot Applicable320,66211-Mar-200804:12Not Applicable
Package_1_for_kb946666~31bf3856ad364e35~ia64~~6.0.1.0.mumNot Applicable2,01411-Mar-200821:57Not Applicable
Package_for_kb946666_server_0~31bf3856ad364e35~ia64~~6.0.1.0.mumNot Applicable1,42911-Mar-200821:57Not Applicable
Package_for_kb946666_server~31bf3856ad364e35~ia64~~6.0.1.0.mumNot Applicable1,43411-Mar-200821:57Not Applicable
Update.mumNot Applicable1,42511-Mar-200821:57Not Applicable
Windowscodecsext.dll6.0.6001.22133644,09611-Mar-200803:43IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about the Windows Imaging Component, visit the following Microsoft Web sites: For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

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Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbqfe, kbhotfixserver, KB946666

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Article Info
Article ID : 946666
Revision : 2
Created on : 5/19/2008
Published on : 5/19/2008
Exists online : False
Views : 381