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The "Font smoothing" feature has no effect in Windows Server 2003 terminal sessions


View products that this article applies to.

Symptoms

You try to connect to a Windows Server 2003-based Terminal Server by using Remote Desktop Connection 6.0 (RDC 6.0). Additionally, you enable the Font smoothing feature on the Experience tab of the Remote Desktop connection dialog box. In this situation, the Font smoothing feature has no effect in the established terminal session.

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Cause

The option to enable the Font smoothing feature is not available in the version of RDC that was released with Windows Server 2003. By default, Windows Server 2003 disables the Font smoothing feature in all remote connections. These connections include the connections that are established through RDC 6.0.

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Resolution

A hotfix is available to resolve this problem. After you apply this hotfix, Windows Server 2003 can either enable or disable the Font smoothing feature in terminal sessions according to the related setting in the remote desktop connection.

Note To enable the Font smoothing feature, Remote Desktop Connection 6.0 must be installed.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

One of the following service packs must be installed before you apply this hotfix:
  • Windows Server 2003 Service Pack 1
  • Windows Server 2003 Service Pack 2

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Registry information

After you apply this hotfix, the following registry entry is added:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows\TSEnableFontSmoothing
By default, the value of the TSEnableFontSmoothing entry is 1. If you do not need this feature, change the value of the TSEnableFontSmoothing entry to 0.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 SP1, x86-based versions and Windows Server 2003 SP2, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Gdi32.dll5.2.3790.3091285,18418-Feb-200813:18x86SP1SP1QFE
Licdll.dll5.2.3790.3125450,04823-Apr-200813:16x86SP1SP1QFE
Win32k.sys5.2.3790.31251,859,07222-Apr-200810:26x86SP1SP1QFE
Winlogon.exe5.2.3790.3125509,44022-Apr-200817:38x86SP1SP1QFE
Licdll.dll5.2.3790.4277469,50423-Apr-200812:31x86SP2SP2QFE
Win32k.sys5.2.3790.42771,849,34422-Apr-200810:29x86SP2SP2QFE
Winlogon.exe5.2.3790.4277528,38422-Apr-200817:35x86SP2SP2QFE
Windows Server 2003 SP1, IA64-based versions and Windows Server 2003 SP2, IA64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Gdi32.dll5.2.3790.3091910,84824-Apr-200804:58IA-64SP1SP1QFE
Win32k.sys5.2.3790.31255,561,85624-Apr-200804:58IA-64SP1SP1QFE
Winlogon.exe5.2.3790.3125679,42424-Apr-200804:58IA-64SP1SP1QFE
Wgdi32.dll5.2.3790.3091288,76824-Apr-200804:58x86SP1WOW
Win32k.sys5.2.3790.42775,566,97624-Apr-200805:16IA-64SP2SP2QFE
Winlogon.exe5.2.3790.4277679,93624-Apr-200805:17IA-64SP2SP2QFE
Windows Server 2003, x64-based versions, Windows XP SP1, x64-based versions, and Windows XP SP2, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Gdi32.dll5.2.3790.3091619,00824-Apr-200805:00x64SP1SP1QFE
Licdll.dll5.2.3790.3125736,25624-Apr-200805:01x64SP1SP1QFE
Win32k.sys5.2.3790.31254,550,14424-Apr-200805:01x64SP1SP1QFE
Winlogon.exe5.2.3790.3125924,67224-Apr-200805:01x64SP1SP1QFE
Wgdi32.dll5.2.3790.3091288,76824-Apr-200805:01x86SP1WOW
Licdll.dll5.2.3790.4277757,76024-Apr-200805:11x64SP2SP2QFE
Win32k.sys5.2.3790.42774,544,00024-Apr-200805:11x64SP2SP2QFE
Winlogon.exe5.2.3790.4277944,12824-Apr-200805:12x64SP2SP2QFE

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
925876 Remote Desktop Connection (Terminal Services Client 6.0)
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for x64-based versions of Microsoft Windows

If your hardware came with a Microsoft Windows x64 edition already installed, your hardware manufacturer provides technical support and assistance for the Windows x64 edition. In this case, your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation by using unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you must have technical help with a Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware. If you purchased a Windows x64 edition such as a Windows Server 2003 x64 edition separately, contact Microsoft for technical support.

For product information about Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Windows Server 2003, visit the following Microsoft Web site:

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Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbqfe, KB946633

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Article Info
Article ID : 946633
Revision : 4
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 378