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Microsoft CRM 3.0 hotfixes remain in Add or Remove Programs


View products that this article applies to.

RAPID PUBLISHING ARTICLES PROVIDE INFORMATION DIRECTLY FROM WITHIN THE MICROSOFT SUPPORT ORGANIZATION. THE INFORMATION THAT IS CONTAINED HEREIN IS CREATED IN RESPONSE TO EMERGING OR UNIQUE TOPICS, OR IS INTENDED TO SUPPLEMENT OTHER KNOWLEDGE BASE INFORMATION.
Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows

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Symptoms

Consider the following scenario:
  1. You installed a hotfix for Microsoft Dynamics CRM 3.0. For example, you installed update rollup 922815.
  2. You upgrade to Microsoft Dynamics CRM 4.0.
  3. Finally, you uninstall Microsoft Dynamics CRM 4.0.
In this scenario, Microsoft Dynamics CRM 3.0 hotfixes still appear in the Add or Remove Programs. For example, 922815 still appears in Add or Remove Programs.

Additionally, several Microsoft Dynamics CRM 3.0 hotfix files also remain in the following directory: <drive>:\Program Files\Microsoft CRM\Server\GAC directory

For example, you may see the following files:
  • Microsoft.Crm.dll
  • Microsoft.Crm.ManagedInterop.dll
  • Microsoft.Crm.ObjectModel.dll
  • Microsoft.Crm.Platform.Callout.Manager.dll
  • Microsoft.Crm.Platform.Proxy.dll
  • Microsoft.Crm.Platform.Sdk.dll
  • Microsoft.Crm.Platform.Server.dll
  • Microsoft.Crm.Scheduling.dll
Some hotfix files may remain in the following directory: <drive>:\Program Files\Microsoft CRM\Tools directory

For example, you may see the following files:
  • CharacterMap.txt
  • Microsoft.Crm.SE.TimeZoneSettings.exe
  • Microsoft.Crm.SE.TimeZoneUpdate.AdminTool.dll
  • MSCRM30ManageAccountAndContactParentRelationships.exe
  • MSCRMFastReassign.exe
  • MSCRMRenameAttributes.exe

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Cause

This problem occurs for the following reasons:
  • The files in the tools directory were not installed by using the Windows Installer (.msi) files. Therefore, the Microsoft Dynamics CRM 3.0 .msi file cannot uninstall them.
  • The files in the GAC directory were updated from a hotfix. Therefore, the Microsoft Dynamics CRM 3.0 .msi file cannot uninstall them because the versions do not match.

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Workaround

To work around this problem, follow these steps.
Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
  1. Delete the following registry subkey: HKLM\Software\Microsoft\Windows\CurrentVersion\Uninstall\<KBNumber>

    Note <KBNumber> is a placeholder for the actual Microsoft CRM hotfix Knowledge Base (KB) number that is listed in Add Or Remove Programs. If you delete the <KBNumber> registry subkey, no hotfix will be displayed in Add or Remove Programs.
  2. Delete any remaining files in the following directories:
    • <drive>:\Program Files\Microsoft CRM\Tools
    • <drive>:\Program Files\Microsoft CRM\Server\GAC directory

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kbexpertisebeginner, kbtshoot, kbmbsmigrate, kbprb, kbexpertiseinter, KB946544

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Article Info
Article ID : 946544
Revision : 2
Created on : 12/21/2007
Published on : 12/21/2007
Exists online : False
Views : 11