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The Autodiscover service fails for some Outlook 2007 users after you install Exchange Server 2007 Service Pack 1


View products that this article applies to.

Symptoms

The Autodiscover service fails for some Microsoft Office Outlook 2007 users after you install Microsoft Exchange Server 2007 Service Pack 1 (SP1). Therefore, users cannot perform several tasks. These tasks include the following:
  • Access free/busy information
  • Access the Outlook Address Book (OAB)
  • Configure the "Out of Office Assistant" feature
  • Automatically configure profiles in Outlook 2007
Note The Autodiscover service is a new service in Exchange Server 2007. The Autodiscover service provides access to Exchange Server features for Outlook 2007 clients that are connected to the Exchange Server messaging environment.

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Cause

This problem occurs if the msExchQueryBaseDN attribute for an Exchange Server user is set to the distinguished name of an address list instead of to the distinguished name of an organizational unit (OU).

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Resolution

To resolve this problem, install Update Rollup 1 for Microsoft Exchange Server 2007 Service Pack 1. For more information about Update Rollup 1 for Exchange Server 2007 Service Pack 1, see the following Exchange Help topic: For more information about how to obtain the latest Exchange service pack or update rollup, see the following Exchange Help topic:

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Workaround

Warning If you use the ADSI Edit snap-in, the LDP utility, or any other LDAP version 3 client, and you incorrectly modify the attributes of Active Directory objects, you can cause serious problems. These problems may require you to reinstall Microsoft Windows 2000 Server, Microsoft Windows Server 2003, Microsoft Exchange 2000 Server, Microsoft Exchange Server 2003, or both Windows and Exchange. Microsoft cannot guarantee that problems that occur if you incorrectly modify Active Directory object attributes can be solved. Modify these attributes at your own risk.

To work around this problem, configure the msExchQueryBaseDN attribute to the distinguished name of the affected user's OU. To do this, follow these steps:
  1. On a server that has the Windows Support Tools installed, open a command prompt.
  2. Move to the Drive_Letter:\Program Files\Support Tools folder.
  3. Type adsiedit.msc, and then press ENTER.
  4. On the Action menu, click Connect to.
  5. In the Connection Settings dialog box, type the name that you want to use for this connection in the Name box.
  6. In the Connection Point area, click Select a well-known Naming Context, and then click Domain in the list.
  7. In the Computer area, click Select or type a Domain or Server, and then type the FQDN of the server in the box. Or, you can click Default (Domain or Server that you logged in to), if it is suitable.
  8. Click OK.
  9. Expand Domain [Server_Name.Domain_Name.Root_Domain], expand DC=Domain_Name,DC=Root_Domain, expand CN=Organizational_Unit_Name, and then expand CN=Users or whichever container contains the affected user.
  10. Right-click CN=User_Name, and then click Properties.

    Note The User_Name placeholder represents the name of the affected user.
  11. In the Attributes list, click msExchQueryBaseDN, and then click Edit.
  12. In the Value box, type the LDAP address that represents that user's organizational unit. For example, type OU=User_OU, DC=User_Domain, dc=COM.
  13. Click OK two times.
  14. On the File menu, click Exit.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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References

For more information about the Autodiscover service, visit the following Microsoft Web site: For more information about the msExchQueryBaseDN attribute, click the following article number to view the article in the Microsoft Knowledge Base:
817218� How to restrict OWA address searches to multiple organizational units
For more information about how to configure virtual organizations and address list segregation in Exchange Server 2007, visit the following Microsoft Web site:

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Keywords: KB946506, kbautodiscovery, kbexpertiseadvanced, kbbug, kbtshoot

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Article Info
Article ID : 946506
Revision : 2
Created on : 3/17/2008
Published on : 3/17/2008
Exists online : False
Views : 406