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A user may be unable to take a PC-Phone call off hold in a Communications Server 2007 environment


View products that this article applies to.

Symptoms

You use the Mediation Server role to connect to a telephone system in a Microsoft Office Communications Server 2007 environment. In this situation, after a user who uses a PC-Phone puts a telephone call on hold, the user may be unable to resume the telephone call.

This problem occurs if the following conditions are all true:
  • The gateway device sends a Session Initiation Protocol (SIP) re-invitation (re-INVITE) request to retrieve the telephone call.

    Note This is a request to change the media direction to send/receive.
  • The SIP re-INVITE request contains an empty Session Description Protocol (SDP).
  • The re-INVITE request has a Content-Type value specified.
Note This problem does not occur if the re-INVITE request that does not have an SDP also does not specify a Content-Type value.

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Cause

This problem occurs because of a problem in Mediation Server. Mediation Server does not handle the conditions that are described in the "Symptoms" section correctly.

If the gateway sends an SIP re-INVITE request that does not have an SDP but that does specify a Content-Type value, Mediation Server responds with a 200 OK response as expected. However, the 200 OK response incorrectly contains a status value of a=inactive.

Note Specifying a Content-Type in a re-INVITE request that does not contain an SDP is optional. Therefore, Mediation Server should handle this kind of re-INVITE request.

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Resolution

How to obtain the hotfix

This issue is fixed in the Communications Server 2007 update package for the Unified Communications Managed API v1.0 Redistribution Hotfix Package that is dated December 17, 2007. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
944285 Description of the Communications Server 2007 update package for the Unified Communications Managed API v1.0 Redistribution: December 17, 2007

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kbnosurvey, kbarchive, kbqfe, kbbug, kbfix, KB946385

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Article Info
Article ID : 946385
Revision : 3
Created on : 1/15/2015
Published on : 1/15/2015
Exists online : False
Views : 48