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How to troubleshoot common mail merge issues in Microsoft Dynamics CRM


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Introduction

This article describes methods that you can use to troubleshoot common issues that may occur when you use the Mail Merge function in Microsoft Dynamics CRM. This article also provides answers to frequently asked questions when you use the Mail Merge function in Microsoft Dynamics CRM.

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More information

Error messages

You cannot track a sent e-mail message by using the Mail Merge function and an e-mail format that differs from HTML

If you use the Mail Merge function to send an e-mail message, Microsoft Dynamics CRM may be unable to track the e-mail message. Therefore, you may receive the following error message:
Process:OUTLOOK |Thread:2112 |Category: Unmanaged.Platform |User: PlatformUser |Level: Error | CMapiEventsHandler::HandleEvent File: c:\bt\596\src\application\outlook\addin\mapieventshandler.cpp Line: 189
>hr = 0x80004005
Cause

This issue may occur when the Mail Merge function uses the plain text mail format or the attachment mail format.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
908024 Error message when you try to mail merge to electronic mail in Word
Workaround

To work around this issue, use the HTML mail format. To do this, follow these steps:
  1. Run the Mail Merge function.
  2. Under Step 4 of 4 in the Merge task pane, click Electronic Mail.
  3. In the Merge to E-mail dialog box, click HTML in the Mail format box, and then click OK.

"Invalid Merge Field" error message when you use an existing mail merge quote template

If you use an existing mail merge quote template that you used for Microsoft Dynamics CRM 3.0, some fields that are used in the Microsoft Dynamics CRM 3.0 data source change in the Microsoft Dynamics CRM 4.0 data source. For example, the "LastItem," "LineItem," "Bill_To," and "Ship_To" fields do not match a Microsoft Dynamics CRM 4.0 field. Additionally, you receive an "Invalid Merge Field" error message.

Resolution

To resolve this problem, map the CRM 3.0 fields in the left column of the following table to the corresponding CRM 4.0 fields in the right column. Map these fields in the existing mail merge quote template.
Microsoft Dynamics CRM 3.0 fieldMicrosoft Dynamics CRM 4.0 field
lineItem_XXXQuote_Product_XXX
Ship_To_StateProvinceShip_To_State_Province
Bill_To_StateProvinceBill_To_State_Province

Error message when you complete a mail merge: "Microsoft Dynamics CRM Mail Merge is already running"

When you try to complete a mail merge operation, you receive the following error message:
Microsoft Dynamics CRM Mail Merge is already running. Only one mail merge can occur at a time. To start a new one, close Microsoft Word, which will stop the current mail merge and then start a new one.

Resolution

To resolve this problem, exit Windows Internet Explorer or Microsoft Office Outlook, depending on the application that you used to start the mail merge operation. Then, restart the mail merge operation.

Administration

Match fields are not set when you use the Mail Merge function

After you perform a mail merge operation from the Microsoft Dynamics CRM Web application, mail merge field mappings are not set when you click Match Fields in the mail merge Microsoft Office Word document. For example, you click Insert Merge Field, and then you click Match Fields to link the Microsoft Dynamics CRM data source fields to the standard Word fields. When you do this, the fields are not automatically matched. Therefore, you cannot use the Address Block and Greeting Line Word mail merge features unless you manually match the Microsoft Dynamics CRM fields to the Word fields.

Workaround

To work around this issue, use one of the following methods:
  • Map the fields manually. For example, map the Microsoft Dynamics CRM "Address 1" field to the Microsoft Word "Address_1_Street_1" field.
  • Use Microsoft Dynamics CRM for Microsoft Office Outlook to perform the mail merge. The Microsoft Dynamics CRM Client software automatically maps the Microsoft CRM fields to the Microsoft Word fields.

The mail merge template is not uploaded when you exit Internet Explorer or Outlook

When you perform a mail merge operation in Microsoft Dynamics CRM and you click Upload Template to CRM, the template is not uploaded to Microsoft Dynamics CRM. This problem occurs if you exit Internet Explorer or Outlook during the merge process.

Workaround

If you want to upload a mail merge template, do not exit Internet Explorer or Outlook until you complete the mail merge process. If you exit Outlook or Internet Explorer, you must restart the mail merge operation to upload the template.

Note You can upload mail merge templates only when you use the Microsoft CRM mail merge functionality in Microsoft Dynamics CRM for Microsoft Office Outlook.

You cannot change the mail merge template when you are offline

When you are offline, the Settings options are not available. Therefore, you cannot change any mail merge templates that you create when you are offline and that you upload to Microsoft Dynamics CRM. You can use this template while you are offline. 

If you must change the mail merge template, use the Microsoft Dynamics CRM Web client. Or, go online in the Microsoft Dynamics CRM Client for Outlook to change the template.

"E-mail via Mail Merge" functionality

The "E-Mail via Mail Merge" functionality does not filter out marketing list members who have no e-mail address

When you use the "E-mail via Mail Merge" functionality, and one of the recipients does not have an e-mail address in Microsoft Dynamics CRM 4.0, the mail merge process includes the recipient without the e-mail address in the mail merge operation.

When a marketing list contains members who do not have an e-mail address, the members are still selected to be added to the Word Mail Merge operation. No e-mail activities are created for these members because they do not have e-mail addresses. However, the users are not listed in the "Excluded or failed" area of the campaign activity.

Resolution

E-mail messages are sent to all the members who have an e-mail address. To send an e-mail, you must enter an e-mail address field for all members in the marketing list. You can create a query in the Advanced Find feature to find the members who do not have an e-mail address. Then, redo the mail merge operation for only those members.
NOTE This issue is fixed in Microsoft Dynamics CRM 2011.

Word Mail Merge toolbar

Activities from a mail merge operation are not created when you use Microsoft Office 2003 together with the Word Mail Merge toolbar

Consider the following scenario:
  • You use the Microsoft Dynamics CRM Mail Merge Wizard.
  • After you accept the merge recipients in Word, you complete the mail merge by using one of the following Word toolbar options:
    • Merge to New Document
    • Merge to Printer or Merge to E-mail
  • Then, you click Create Microsoft Dynamics CRM activities.
In this scenario, the activities are not created.

Resolution

If you use Microsoft Office Word 2003, you must use the Microsoft Dynamics CRM Mail Merge Wizard to complete the merge operation. The Merge to New Document, Merge to Printer, and Merge to E-mail Word 2003 toolbar options do not trigger the events that are used to create the activities in Microsoft Dynamics CRM.
NOTE This issue is fixed in Microsoft Dynamics CRM 2011.

You receive unexpected results when you change the mail merge type in Word

You create a mail merge operation in Microsoft Dynamics CRM. You select a mail merge type in the Microsoft Dynamics CRM Mail Merge Wizard. For example you select the Letter type. The merge operation opens Word. In Word, you change the mail merge type from Letter to E-mail. The mail merge operation may be completed but with error messages, or the mail merge operation may completed with incorrect results.

Workaround

To work around this problem, do not change the mail merge type in Word after Word starts. If you must change the mail merge type, restart the mail merge operation from Microsoft Dynamics CRM, and then select a different mail merge type.

Mail merge quote template

The SalesRep field in the mail merge quote template lists the GUID value

If you use the mail merge quote template that is included with Microsoft Dynamics CRM, the SalesRep field lists the GUID value instead of the actual SalesRep full name. For example, the SalesRep field lists {9F21B628-EBA4-DC11-9FD0-000CF1CCD38F} instead of the actual SalesRep full name.

Note The GUID value is the value that is stored in the Microsoft CRM database for the user who owns the quote record.

Resolution

To resolve this issue, edit the default mail merge quote template to remove the owner of the SalesRep field. Then, add the owner_full_name field. To do this, follow these steps:
  1. Print and save the default mail merge template by using a different name. To do this, follow these steps:
    1. Open a quote in the Microsoft Dynamics CRM Web client, and then click Print Quote for Customer.
    2. Click Organizational Template, click Quote For Customer, and then click OK.
    3. Click OK to start the mail merge operation.
    4. Click Open.

      Note If you are using the 2007 Microsoft Office system, you must click Options, click Enable this content, and then click OK. Then, you can use the CRM macros for the mail merge template.
    5. On the Addins tab, click CRM.
    6. Click OK on the Mail Merge Recipients page of the Mail Merge Wizard.
    7. On the File menu, point to Save As, and then click Other Formats.
    8. Browse to a folder in which you want to save the template.
    9. Type a file name in the File Name box, click Word XML Document(*.xml) in the Save as type list, and then click Save.
    10. Close the Mail Merge Wizard.
  2. Create a new mail merge quote template. To do this, follow these steps:
    1. In the Microsoft Dynamics CRM Web client, click Settings, click Templates, click Mail Merge Template, and then click New.
    2. Type a name, click Quote in the Associated Entity list, and then click Save.
    3. Modify the data fields to remove one field that will not be used. The maximum number of fields is already used. The maximum number of fields is 62.

      For example, you may remove the Salesperson field from the Related Quote Products (Quote Product) entity type. To do this, follow these steps:
      1. Under Select data fields, click Data Fields.
      2. In the Entity Type list, click Related Quote Products (Quote Product).
      3. Click to clear the SalesPerson check box.
      4. In the Entity Type list, click Owner (User).
      5. Click Full Name, and then click OK.
      6. Click Save.
      7. Click Browse, locate the quote template that you saved in step 1, click Open, and then click Attach.
      8. Click Save.
  3. Edit the mail merge fields on the quote template. To do this, follow these steps:
    1. In Word, click Edit Template.
    2. Click Open.

      Note If you are using the 2007 Office system, you must click Options, click Enable this content, and then click OK. Then, you can use the CRM macros for the mail merge template.
    3. On the Mailings tab, click CRM.
    4. On the Mail Merge Recipients page of the Mail Merge Wizard, click OK.
    5. To view the mail merge fields, press ALT+F9.
    6. Drag the pointer to select {MERGEFIELD "Owner"}, and then press DELETE.
    7. Click Insert Merge Fields, double-click Owner_Full_Name in the Fields list, and then click Close.
    8. On the File menu, point to Save As, and then click Other Formats.
    9. Browse to a folder in which you want to save the template.
    10. Type a file name in the File Name box, click Word XML Document(*.xml) in the Save as type list, and then click Save.
    11. Close the Mail Merge Wizard.
  4. Update the mail merge quote template. To do this, follow these steps:
    1. Open the mail merge template that you saved in step 2.
    2. Under File Name, click Remove to remove the existing mail merge template.
    3. Click Browse, locate the updated mail merge quote template that you saved in step 3, click Open, and then click Attach.
    4. Click Save and Close.
More Information

The mail merge template is created as a Personal Mail Merge template type. If you want to make the template available to the organization, follow these steps:
  1. In the Microsoft CRM Web client, click Settings, click Templates, click Mail Merge Template, and then click the template that you created.
  2. Click Actions, click Make Available to Organization, click OK, and then click Save and Close.

Line item fields are missing from the default mail merge quote template

When you use the default mail merge quote template in Microsoft Dynamics CRM, the following fields are missing from the line item calculation:
  • Tax
  • Manual Discount
  • Volume Discount
The line item total extended amount calculation is correct. However, the default template does not list these fields for each line item.

Resolution

To resolve this issue, modify the default mail merge quote template. Or, create a new mail merge quote template that includes these fields.

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Keywords: kbmbscrmonline, kbmbscrmonlineoutlook, kbmbsemail, kbfreshness2008, kbexpertiseinter, kbhowto, kbinfo, kbmbsmigrate, kbexpertisebeginner, KB946273

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Article Info
Article ID : 946273
Revision : 4
Created on : 1/4/2011
Published on : 1/4/2011
Exists online : False
Views : 58