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Outlook 2003 or Outlook 2007 exits unexpectedly after you close an e-mail message in a Microsoft Dynamics CRM 3.0 client for Outlook


View products that this article applies to.

Symptoms

After you install the Microsoft Dynamics CRM 3.0 desktop client for Microsoft Office Outlook or the Microsoft Dynamics CRM 3.0 laptop client for Microsoft Office Outlook on a computer that is running Microsoft Office Outlook 2003 or Microsoft Office Outlook 2007, Outlook 2003 or Outlook 2007 exits unexpectedly and then restarts after you close an e-mail message in Outlook.

If platform tracing is enabled, you see error messages in the platform trace file that resemble the following:
[ Date Time ] Process:OUTLOOK |Thread:3024 |Category: Unmanaged.Platform |User: PlatformUser |Level: Error | CMAPIEventsListener::OnStoreNotify() received a notification of type 16 Function: CMAPIEventsListener::OnStoreNotify File: z:\crm\v3rtm-2\src\application\outlook\addin\mapieventslistener.cpp Line: 384

[ Date Time ] Process:OUTLOOK |Thread:3024 |Category: Unmanaged.Platform |User: PlatformUser |Level: Error | CMAPIEventsListener::OnStoreNotify() received a notification of type 16 Function: CMAPIEventsListener::OnStoreNotify File: z:\crm\v3rtm-2\src\application\outlook\addin\mapieventslistener.cpp Line: 384

[ Date Time ] Process:OUTLOOK |Thread:3024 |Category: Unmanaged.Platform |User: PlatformUser |Level: Error | Inspector wrapper with id {7E6EB0A0-F4A4-DC11-900E-0003FF239E2E} was shut down Function: CInspectorWrapper::InspectorShutdown File: z:\crm\v3rtm-2\src\application\outlook\addin\inspectorwrapper.cpp Line: 858

[ Date Time ] Process:OUTLOOK |Thread:3024 |Category: Unmanaged.Platform |User: PlatformUser |Level: Error | Inspector wrapper with id {4C169BB1-F4A4-DC11-900E-0003FF239E2E} was shut down Function: CInspectorWrapper::InspectorShutdown File: z:\crm\v3rtm-2\src\application\outlook\addin\inspectorwrapper.cpp Line: 858
You receive this error message if you have enabled platform tracing by using the method that is described in Microsoft Knowledge Base article 907490.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
907490� How to enable tracing in Microsoft Dynamics CRM
You receive this error message in the platform trace files, starting with the name in the following format:
OUTLOOK- xxxxxxxxxx.log
The xxxxxxxxxx placeholder represents the year, the month, the day, and the time of the platform trace file.

Additionally, you may see events in the Application log that resemble the following:
Source: Microsoft Office 11
Category: None
EventID: 1002
Hanging application OUTLOOK.EXE, version 11.0.8118.0, hang module hungapp, version 0.0.0.0, hang address 0x00000000.
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Source: Microsoft Office 11
Category: None
EventID: 1000
Faulting application outlook.exe, version 11.0.8118.0, stamp 456628bf, faulting module outllib.dll, version 11.0.8118.0, stamp 4566283d, debug? 0, fault address 0x002492bb. For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
This problem does not occur if you have installed the Microsoft Dynamics CRM 3.0 clients for Microsoft Office Outlook Compatibility Update.

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Cause

This problem occurs if you installed hotfix 924085 for Outlook 2003 or for Outlook 2007.

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Resolution

This problem was corrected in Microsoft Dynamics CRM 3.0 Update Rollup 3. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935364� Update Rollup 3 is available for Microsoft Dynamics CRM 3.0

Microsoft Dynamics CRM 3.0, Japanese version or Chinese version

This problem is fixed in the Chinese Simplified version of Microsoft Dynamics CRM 3.0 and in the Japanese version of Microsoft Dynamics CRM 3.0 Update Rollup 2. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
944372� Update Rollup 2 for the Chinese Simplified version of Microsoft Dynamics CRM 3.0 and for the Japanese version of Microsoft Dynamics CRM 3.0 is available

Hotfix information for Microsoft Dynamics CRM 3.0

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Microsoft Dynamics CRM 3.0 client for Outlook

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimeHashesPlatform
Crmaddin.dll3.0.5300.18021,193,48831-Jan-200823:35MD5: 181368D572E11D1FD3E1F4B191BB3590
SHA1: 8A634F1AFE3714C7F920E9BC129F62BF55F71330
x86

Microsoft Dynamics CRM 3.0 client for Outlook Compatibility Update

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimeHashesPlatform
Crmaddin.dll3.0.5300.18021,219,60031-Jan-200823:35MD5: DBBF97DDFA7E3ABA846F0C6501F77DDD
SHA1: 5FB9E508CE8DA42D26290A62EB9C8F13738A1DE1
x86
Syncqueue.dll3.0.5300.1802395,79231-Jan-200823:34MD5: 20BD719018C9A3DFAC47A49E8657F4FA
SHA1: 90632E8CFB4B8BD1A072D351962D5DD6A7BAF4BF
x86
Crmaddin.dll3.0.5300.18021,219,60031-Jan-200823:35MD5: DBBF97DDFA7E3ABA846F0C6501F77DDD
SHA1: 5FB9E508CE8DA42D26290A62EB9C8F13738A1DE1
x86

Installation information

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756� How to back up and restore the registry in Windows
Install this hotfix on computers that are running the Microsoft Dynamics CRM 3.0 client for Outlook.

To resolve this problem, follow these steps:
  1. Exit Outlook by using Windows Task Manager.
  2. Click Start, click Run, type regedit, and then click OK.
  3. Locate and then click the following registry entry:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\MSCRMClient
  4. Locate the CallInspectorClose subkey.

    If the CallInspectorClose subkey does not exist, create the CallInspectorClose subkey. To do this, follow these steps:
    1. On the Edit menu, point to New, and then click DWORD Value.
    2. Type CallInspectorClose, and then press ENTER.
  5. Right-click CallInspectorClose, and then click Modify.
  6. In the Value data box, type 0x00000000, and then click OK.

    Notes
    • If you have Outlook 2003 or Outlook 2007 installed and you do not have hotfix 924085 installed, the value of the CallInspectorClose subkey must be set to 0x00000001. Or, you can remove the CallInspectorClose subkey.
    • If you have Outlook 2003 or Outlook 2007 installed and you have hotfix 924085 installed, the value of the CallInspectorClose subkey must be set to 0x00000000 to prevent crashes. If you do not set the CallInspectorClose subkey to 0x00000000, memory leaks may occur after you close a window in Outlook.

Prerequisites

You must have Update Rollup 2 for Microsoft Dynamics CRM 3.0 installed to apply this hotfix. For more information about Update Rollup 2 for Microsoft Dynamics CRM 3.0, click the following article numbers to view the articles in the Microsoft Knowledge Base:
927751� Update Rollup 2 for Microsoft Dynamics CRM 3.0 is available

Restart requirement

If you are prompted, restart the computer after you install the hotfix.

Removal information

To remove this hotfix from a computer that is running Windows Server 2003, Windows XP, or Windows 2000, use Add or Remove Programs in Control Panel. System administrators can use the Spuninst.exe tool to remove this hotfix from a computer that is running Windows Server 2003, Windows XP, or Windows 2000.

The Spuninst.exe tool is located in the %Windir%\$NTUninstallKB946131$\Spuninst folder.

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Workaround

To work around this problem, uninstall the Microsoft Dynamics CRM 3.0 desktop client for Outlook or the Microsoft Dynamics CRM 3.0 laptop client for Outlook.Then, reinstall the Microsoft Dynamics CRM 3.0 clients for Microsoft Office Outlook Compatibility Update.

For more information about the Microsoft Dynamics CRM 3.0 clients for Microsoft Office Outlook Compatibility Update, visit the following Web site:

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More information

For more information about the terminology that is used to describe Microsoft software updates, click the following article numbers to view the articles in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates
887283� Microsoft Business Solutions CRM software hotfix and update package naming standards
For more information about hotfix 924085, click the following article number to view the article in the Microsoft Knowledge Base:
924085� Description of the security update for Outlook 2003: January 9, 2007
For more information about how to use ADPlus to troubleshoot "hangs" and "crashes" , click the following article number to view the article in the Microsoft Knowledge Base:
286350� How to use ADPlus to troubleshoot "hangs" and "crashes"

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Keywords: KB946131, kbmbsmigrate, kbqfe, kbhotfixserver, kberrmsg, kbautohotfix

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Article Info
Article ID : 946131
Revision : 6
Created on : 6/11/2008
Published on : 6/11/2008
Exists online : False
Views : 335