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The handle count of the Smlogsvc.exe process continues to increase when you use the "Performance Logs and Alerts" MMC snap-in in Windows Server 2003


View products that this article applies to.

Symptoms

Consider the following scenario:
  • In Windows Server 2003, you use the Performance Logs and Alerts Microsoft Management Console (MMC) snap-in or the Logman.exe tool in order to log performance data.
  • Multiple performance logs are used at the same time.
  • You frequently start or stop these performance logs.
In this scenario, the handle count of the Smlogsvc.exe process continues to increase. If you use Process Explorer or the Handle.exe tool to monitor the Smlogsvc.exe process, you may find that handles remain open to registry subkeys that are under the following subkey:
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\SysmonLog\Log Queries
For example, handles remain open to the following registry subkeys:
  • HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\SysmonLog\Log Queries\{3c93fd73-c0ac-4f16-a6ae-1b7fa9840d2f}
  • HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\SysmonLog\Log Queries\{0275a8da-1a31-4662-a420-a35bb47230d4}
  • HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\SysmonLog\Log Queries\{613f7365-0671-4146-9945-c24547a42827}
  • HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\SysmonLog\Log Queries\{31e3e682-f62e-4114-9bf7-52c5345fc9ce}
  • HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\SysmonLog\Log Queries\{08551f62-6c0f-4819-a061-d32c1b346258}
  • HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\SysmonLog\Log Queries\{46fab8ee-d53a-4b17-8c07-27ecd9c98d7f}
  • HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\SysmonLog\Log Queries\{4f2f0f2f-9d83-4b79-aa95-baa0dac49d32}
  • HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\SysmonLog\Log Queries\{613f7365-0671-4146-9945-c24547a42827}

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Cause

A handle leak occurs because the Performance Logs and Alerts service incorrectly manages registry handles.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Smlogsvc.exe5.2.3790.305896,25613-Dec-200712:26x86
Windows Server 2003 with Service Pack 2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Smlogsvc.exe5.2.3790.420496,25613-Dec-200718:46x86
Windows Server 2003 with Service Pack 1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Smlogsvc.exe5.2.3790.3058231,93613-Dec-200720:21IA-64SP1Not Applicable
Wsmlogsvc.exe5.2.3790.305896,25613-Dec-200720:21x86SP1WOW
Windows Server 2003 with Service Pack 2, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Smlogsvc.exe5.2.3790.4204231,93613-Dec-200720:34IA-64SP2Not Applicable
Wsmlogsvc.exe5.2.3790.420496,25613-Dec-200720:34x86SP2WOW
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Smlogsvc.exe5.2.3790.3058133,12013-Dec-200720:21x64SP1Not Applicable
Wsmlogsvc.exe5.2.3790.305896,25613-Dec-200720:21x86SP1WOW
Windows Server 2003 with Service Pack 2, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Smlogsvc.exe5.2.3790.4204133,12013-Dec-200720:40x64SP2Not Applicable
Wsmlogsvc.exe5.2.3790.420496,25613-Dec-200720:40x86SP2WOW

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Workaround

To work around this problem, restart the Performance Logs and Alerts service.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about Process Explorer, visit the following Microsoft Web site:For more information about the Handle.exe tool, visit the following Microsoft Web site:For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseinter, kbwinserv2003postsp2fix, kbbug, kbfix, kbhotfixserver, kbqfe, KB946118

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Article Info
Article ID : 946118
Revision : 5
Created on : 12/26/2007
Published on : 12/26/2007
Exists online : False
Views : 241