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DNS name resolution does not work on Windows Server 2003


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Source: Microsoft Support

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Rapid publishing

RAPID PUBLISHING ARTICLES PROVIDE INFORMATION DIRECTLY FROM WITHIN THE MICROSOFT SUPPORT ORGANIZATION. THE INFORMATION CONTAINED HEREIN IS CREATED IN RESPONSE TO EMERGING OR UNIQUE TOPICS, OR IS INTENDED SUPPLEMENT OTHER KNOWLEDGE BASE INFORMATION.

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Result

On the Windows Server 2003 computer, you are unable to perform DNS name resolution. You may experience the following issues:

Ping www.microsoft.com , you get a �host not found� error.

If you create a hosts file and put the record into the hosts file, the same issue occurs.

If you use the NSLOOKUP tool to query the record, it may work.

If you collect a Network Monitor trace, you find that there is no DNS packet coming out from the computer.

If you Ping localhost, it fails too.

When the problem happens, the DNS Client Service is up and running.

Clearing the DNS resolver cache, IP Reset, Winsock Reset may not help.

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Cause

This problem may occur if the following registry values were deleted.

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]

"Domain"=""
"NV Domain"=""

This may happen If the Windows Server 2003 computer is imaged using the some imaging software.

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Resolution



Create these two REG_SZ values. If the computers are members of a Windows 2003 domain, by default these two values should be the Domain DNS name.

1. Launch Registry Editor and locate the following key.

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]

2. In the right pane, find these two REG_SZ values:

"Domain"
"NV Domain"

If the values do not exist, manually create them.

3. Modify the data of these two values so that they are the DNS name of the domain. For example, if the domain is named mydomain.com, then the data of these two values should be mydomain.com too.

4. Exit Registry Editor and reboot the computer.

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Disclaimer

MICROSOFT CORPORATION AND/OR ITS RESPECTIVE SUPPLIERS MAKE NO REPRESENTATIONS ABOUT THE SUITABILITY, RELIABILITY, OR ACCURACY OF THE INFORMATION AND RELATED GRAPHICS CONTAINED HEREIN. ALL SUCH INFORMATION AND RELATED GRAPHICS ARE PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT AND/OR ITS RESPECTIVE SUPPLIERS HEREBY DISCLAIM ALL WARRANTIES AND CONDITIONS WITH REGARD TO THIS INFORMATION AND RELATED GRAPHICS, INCLUDING ALL IMPLIED WARRANTIES AND CONDITIONS OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, WORKMANLIKE EFFORT, TITLE AND NON-INFRINGEMENT. YOU SPECIFICALLY AGREE THAT IN NO EVENT SHALL MICROSOFT AND/OR ITS SUPPLIERS BE LIABLE FOR ANY DIRECT, INDIRECT, PUNITIVE, INCIDENTAL, SPECIAL, CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF USE, DATA OR PROFITS, ARISING OUT OF OR IN ANY WAY CONNECTED WITH THE USE OF OR INABILITY TO USE THE INFORMATION AND RELATED GRAPHICS CONTAINED HEREIN, WHETHER BASED ON CONTRACT, TORT, NEGLIGENCE, STRICT LIABILITY OR OTHERWISE, EVEN IF MICROSOFT OR ANY OF ITS SUPPLIERS HAS BEEN ADVISED OF THE POSSIBILITY OF DAMAGES.

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Keywords: KB945980, kbrapidpub, kbnomt

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Article Info
Article ID : 945980
Revision : 1
Created on : 12/5/2007
Published on : 12/5/2007
Exists online : False
Views : 294