Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Installation of Windows 2003 Service pack fails when WMI breaks


View products that this article applies to.

Rapid publishing

Source: Microsoft Support

↑ Back to the top


Result

RAPID PUBLISHING ARTICLES PROVIDE INFORMATION DIRECTLY FROM WITHIN THE MICROSOFT SUPPORT ORGANIZATION. THE INFORMATION CONTAINED HEREIN IS CREATED IN RESPONSE TO EMERGING OR UNIQUE TOPICS, OR IS INTENDED SUPPLEMENT OTHER KNOWLEDGE BASE INFORMATION.

↑ Back to the top


Cause



The installation of Windows 2003 Service pack failed, and you received the following error:

"An error in updating your system occurred. click ok to continue"

In the SVCPACK.Log file, you see lines similar to the followings:

1142.453: Starting process: C:\WINDOWS\system32\wbem\mofcomp.exe C:\WINDOWS\system32\wbem\wlbsprov.mof
1142.860: Return Code = 3
1142.860: Starting process: C:\WINDOWS\system32\wbem\mofcomp.exe C:\WINDOWS\system32\wbem\cimwin32.mof
1145.375: Return Code = 3

609.688: DoInstallation:RunInfProcesses for ProcessesToRun Failed
609.688: Service Pack 2 Setup encountered an error: An error in updating your system has occurred.





↑ Back to the top


Resolution



This normally happens when there are issues with WMI.

↑ Back to the top


Moreinformation



1. If the WMI service is not started, try to start it. Then test to see if the issue is resolved.

2. Troubleshoot the WMI issue. For more information about how to do this, visit the following Microsoft Web site:

http://www.microsoft.com/technet/scriptcenter/topics/help/wmidiag.mspx

Workaround:

A workaround to this is to rebuild the WMI Repository.
Warning: This is not suitable if there is critical data stored in the WMI namespace because rebuilding will lose the data. Also, the namespaces of non-Windows products are not rebuilt using the steps below. For example, Exchange WMI namespaces would not regenerate after rebuilding, and this may require a reinstallation of Exchange.

1. Back up the WBEM folder (%windir%\system32\wbem) and then copy the WBEM folder from a freshly installed computer with the same version and service pack level.

2. Run the following steps in a command prompt:

cd %windir%\system32\wbem
for /f %s in ('dir /b *.dll') do regsvr32 /u /s %s
for /f %s in ('dir /b *.dll') do regsvr32 /s %s
wmiprvse /regserver
winmgmt /regserver

↑ Back to the top


Disclaimer



For more information about Windows Management Instrumentation, refer to the link below:

http://www.microsoft.com/technet/community/en-us/management/wmi_faq.mspx

↑ Back to the top


Keywords: KB945763, kbrapidpub, kbnomt

↑ Back to the top

Article Info
Article ID : 945763
Revision : 2
Created on : 11/30/2007
Published on : 11/30/2007
Exists online : False
Views : 169