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When you try to shut down or to restart a Windows Server 2003-based computer that has USB devices connected, the computer stops responding and displays a black screen


View products that this article applies to.

Symptoms

Consider the following scenario.
  • You are running a Windows Server 2003-based computer.
  • You have USB devices connected to the computer. For example, you have a USB keyboard and a USB mouse connected.
  • You try to shut down or to restart the computer.
In this scenario, the shut-down process stops responding (hangs), and then the system displays a black screen. You have to manually turn off the computer to recover.

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Cause

This problem occurs because a deadlock is introduced when the system cleans the USB I/O requests during the shut-down process.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 installed.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 Service Pack 1, x86-based versions
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File nameFile versionFile sizeDateTimePlatformSP requirement
Usbehci.sys5.2.3790.304430,72014-Nov-200712:01Not ApplicableSP1
Usbohci.sys5.2.3790.304417,53614-Nov-200712:01Not ApplicableSP1
Usbport.sys5.2.3790.3044146,43214-Nov-200712:01x86SP1
Usbuhci.sys5.2.3790.304420,99214-Nov-200712:01Not ApplicableSP1
Windows Server 2003 Service Pack 2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Usbehci.sys5.2.3790.418930,72014-Nov-200712:24Not ApplicableSP2
Usbohci.sys5.2.3790.418917,53614-Nov-200712:24Not ApplicableSP2
Usbport.sys5.2.3790.4189146,43214-Nov-200712:24x86SP2
Usbuhci.sys5.2.3790.418920,99214-Nov-200712:24Not ApplicableSP2
Windows Server 2003 Service Pack 1, Itanium architecture versions
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File nameFile versionFile sizeDateTimePlatformSP requirement
Usbehci.sys5.2.3790.3044100,86414-Nov-200714:23Not ApplicableSP1
Usbohci.sys5.2.3790.304450,30414-Nov-200714:23Not ApplicableSP1
Usbport.sys5.2.3790.3044415,23214-Nov-200714:23IA-64SP1
Usbuhci.sys5.2.3790.304472,19214-Nov-200714:23Not ApplicableSP1
Windows Server 2003 Service Pack 2, Itanium architecture versions
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File nameFile versionFile sizeDateTimePlatformSP requirement
Usbehci.sys5.2.3790.4189100,86414-Nov-200714:28Not ApplicableSP2
Usbohci.sys5.2.3790.418950,30414-Nov-200714:28Not ApplicableSP2
Usbport.sys5.2.3790.4189415,23214-Nov-200714:28IA-64SP2
Usbuhci.sys5.2.3790.418972,19214-Nov-200714:28Not ApplicableSP2
Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Usbehci.sys5.2.3790.304452,22414-Nov-200714:24x64SP1
Usbohci.sys5.2.3790.304426,88014-Nov-200714:24x64SP1
Usbport.sys5.2.3790.3044214,01614-Nov-200714:24x64SP1
Usbuhci.sys5.2.3790.304432,89614-Nov-200714:24x64SP1
Windows Server 2003 Service Pack 2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Usbehci.sys5.2.3790.418952,22414-Nov-200714:30x64SP2
Usbohci.sys5.2.3790.418926,88014-Nov-200714:31x64SP2
Usbport.sys5.2.3790.4189214,01614-Nov-200714:31x64SP2
Usbuhci.sys5.2.3790.418932,89614-Nov-200714:31x64SP2

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseinter, kbfix, kbqfe, kbHotfixServer, KB944704

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Article Info
Article ID : 944704
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 269