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You may be unable to print a job after you install the .NET Framework 3.0 or the XML Paper Specification Essentials Pack on a Windows XP SP2-based computer or on a Windows Server 2003-based computer


View products that this article applies to.

Symptoms

On a Windows XP Service Pack 2 (SP2)-based computer or on a Windows Server 2003-based computer, you may be unable to print a job after you install the Microsoft .NET Framework 3.0 or the Microsoft XML Paper Specification Essentials Pack on the computer.

Note This problem occurs only when the banding technology is turned on in the printer driver.

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Cause

This problem occurs because the printer driver cannot call the DrvQueryFont function. Therefore, the printer driver cannot receive the rendering Device Driver Interface (DDI) calls after you install the .NET Framework 3.0 or the XML Paper Specification Essentials Pack.

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Resolution

Windows XP hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) or Service Pack 2 (SP2) installed on the computer.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP with Service Pack 2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Unidrv.dll0.3.6000.20691372,73631-Oct-200710:54x86SP2
Unidrvui.dll0.3.6000.20691744,44831-Oct-200710:54x86SP2

Windows Server 2003 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 2 (SP2) installed on the computer.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Unidrv.dll0.3.6000.20691472,06402-Nov-200710:24x64SP2
Unidrvui.dll0.3.6000.20691883,71202-Nov-200710:24x64SP2
Windows Server 2003, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Unidrv.dll0.3.6000.20691372,73602-Nov-200707:36x86SP2
Unidrvui.dll0.3.6000.20691744,44802-Nov-200707:36x86SP2

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

Banding is a technique that is used to implement the full functionality of the Windows Graphics Device Interface (GDI) in printer drivers that can only print bitmaps for graphics.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
75471� INFO: Basics of Banding Printing in Windows
The DrvQueryFont function is used by GDI to obtain the IFIMETRICS structure for a given font. For more information, visit the following Microsoft Web site:For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbwinxppresp3fix, kbexpertiseadvanced, kbbug, kbfix, kbhotfixserver, kbqfe, KB944203

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Article Info
Article ID : 944203
Revision : 4
Created on : 11/27/2007
Published on : 11/27/2007
Exists online : False
Views : 282