Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A Windows Server 2003-based DHCP server that has a single deactivated scope still responds to DHCP INFORM packets from clients, and therefore network access problems occur


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You configure two Windows Server 2003-based DHCP servers to manage a network subnet.
  • One server is the primary DHCP server, and the other is the secondary DHCP server.
  • You configure a single scope on the secondary DHCP server. Then, you deactivate this scope.
In this scenario, the secondary DHCP server still responds to DHCP INFORM packets from clients by using the information from the deactivated scope. However, in its response, the server may send unexpected options to the clients. This problem may affect the IP settings and the network access of the clients.

You expect a DHCP server that has deactivated scopes configured not to use the information from these deactivated scopes when it responds to any DHCP INFORM packets from clients. If the server has other valid scopes configured, the response should be sent only to clients in the subnets that the valid scopes match. If you deactivate all the scopes on the server, this server should behave the same as a server that has no scopes configured.

↑ Back to the top


Cause

This problem occurs because a Windows Server 2003-based DHCP server does not determine whether the scope is active when the server responds to the DHCP INFORM packets.

↑ Back to the top


Resolution

A hotfix is available to resolve this problem. After you install this hotfix, the Windows Server 2003-based DHCP server that has a single deactivated scope does not respond to the DHCP INFORM packets from the clients by using the information from the deactivated scope.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must one of the following service packs installed to apply this hotfix:
  • Windows Server 2003 service pack 1
  • Windows Server 2003 service pack 2

Restart requirement

You must restart the DHCP service after you install this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with SP1, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Dhcpssvc.dll5.2.3790.3034271,87226-Oct-200718:49x86
Windows Server 2003 with SP2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Dhcpssvc.dll5.2.3790.4177270,84826-Oct-200719:14x86
Windows Server 2003 with SP1, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dhcpssvc.dll5.2.3790.3034434,17626-Oct-200717:06x64SP1Not Applicable
Wdhcpssvc.dll5.2.3790.3034271,87226-Oct-200717:06x86SP1WOW
Windows Server 2003 with SP2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dhcpssvc.dll5.2.3790.4177432,64026-Oct-200717:14x64SP2Not Applicable
Wdhcpssvc.dll5.2.3790.4177270,84826-Oct-200717:14x86SP2WOW
Windows Server 2003 with SP1, IA-64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dhcpssvc.dll5.2.3790.3034735,74426-Oct-200717:06IA-64SP1Not Applicable
Wdhcpssvc.dll5.2.3790.3034271,87226-Oct-200717:06x86SP1WOW
Windows Server 2003 with SP2, IA-64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dhcpssvc.dll5.2.3790.4177732,67226-Oct-200717:12IA-64SP2Not Applicable
Wdhcpssvc.dll5.2.3790.4177270,84826-Oct-200717:12x86SP2WOW

↑ Back to the top


Workaround

To work around this problem, delete the scope instead of deactivating it.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbqfe, kbHotfixServer, KB944200

↑ Back to the top

Article Info
Article ID : 944200
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 237