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Authorization Manager in Windows Server 2003 cannot add roles from other domains in the forest after security update 926122 or Windows Server 2003 Service Pack 2 is installed


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a Windows Server 2003 parent domain and a Windows Server 2003 child domain.
  • Authorization Manager is installed on servers in the parent domain or on servers in the child domain.
  • Security update 926122 or Windows Server 2003 Service Pack 2 is installed on the servers where Authorization Manager is installed. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
    926122 MS07-039: Vulnerability in Windows Active Directory could allow remote code execution
In this scenario, you cannot add user accounts from one domain to a role that is in the Authorization Manager store of the other domain. Also, you cannot delete user accounts in one domain from a role that is in the Authorization Manager store of the other domain.

At this point, the operation appears to be successful in the user interface. However, after you close and then reopen Authorization Manager, the user interface presents the settings as they were before the operation.

Additionally, when you try to add new users to a user group by using their object globally unique identifiers (GUIDs), you receive the following Lightweight Directory Access Protocol (LDAP) error message:
DSA is unwilling to perform (53)

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Cause

Authorization Manager cannot add a user security identifier (SID) that resides in another domain to a role. Also, Authorization Manager cannot delete a user SID that resides in another domain from a role.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You may have to restart the computer if the Azroles.dll file is being used.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Azroles.dll5.2.3790.3038234,49602-Nov-200703:31x86
Windows Server 2003 with Service Pack 2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Azroles.dll5.2.3790.4181234,49602-Nov-200707:25x86
Windows Server 2003 with Service Pack 1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Azroles.dll5.2.3790.3038710,14402-Nov-200705:38IA-64SP1Not Applicable
Wazroles.dll5.2.3790.3038234,49602-Nov-200705:38x86SP1WOW
Windows Server 2003 with Service Pack 2, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Azroles.dll5.2.3790.4181710,14402-Nov-200705:40IA-64SP2Not Applicable
Wazroles.dll5.2.3790.4181234,49602-Nov-200705:40x86SP2WOW
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Azroles.dll5.2.3790.3038419,84002-Nov-200705:39x64SP1Not Applicable
Wazroles.dll5.2.3790.3038234,49602-Nov-200705:39x86SP1WOW
Windows Server 2003 with Service Pack 2, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Azroles.dll5.2.3790.4181419,84002-Nov-200705:44x64SP2Not Applicable
Wazroles.dll5.2.3790.4181234,49602-Nov-200705:44x86SP2WOW

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Workaround

To work around this problem, follow these steps:
  1. Create a local group in the domain where the Authorization Manager store resides.
  2. Add the user account from another domain to the local group.
  3. Assign the role to the local group.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseinter, kbwinserv2003postsp2fix, kbbug, kbfix, kbhotfixserver, kbqfe, KB943875

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Article Info
Article ID : 943875
Revision : 3
Created on : 11/28/2007
Published on : 11/28/2007
Exists online : False
Views : 229