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Error message when you run the


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Symptoms

Consider the following scenario:
You install Microsoft iSCSI Software Initiator version 2.04 on a computer that is running an x64-based version of Windows Server 2003.
You run the following command by using the 64-bit Iscsicli.exe utility on the computer.
iscsicli ping
In this scenario, you receive the following error message:
Not enough storage is available to process this command.
Additionally, If you check the memory usage of the Iscsicli.exe utility, you may find that the Iscsicli.exe utility consumes 2 gigabytes (GB) of virtual memory.

Note The problem does not occur if you use a 32-bit Iscsicli.exe utility.

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Cause

This problem is caused by the 64-bit Iscsidsc.dll module and by the Iscsicli.exe utility. When the command iscsicli ping is handled, the 64-bit Iscsidsc.dll module and the Iscsicli.exe utility do not manage memory allocation well. Therefore, the Iscsicli.exe utility incorrectly allocates 2 GB of virtual memory on the computer.

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More information

Technical support for x64-based versions of Microsoft Windows

If your hardware came with a Microsoft Windows x64 edition already installed, your hardware manufacturer provides technical support and assistance for the Windows x64 edition. In this case, your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation by using unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you must have technical help with a Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware. If you purchased a Windows x64 edition such as a Windows Server 2003 x64 edition separately, contact Microsoft for technical support.

For product information about Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Windows Server 2003, visit the following Microsoft Web site:

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: KB943664, kbtshoot, kbexpertiseinter, kbprb

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Article Info
Article ID : 943664
Revision : 3
Created on : 11/7/2007
Published on : 11/7/2007
Exists online : False
Views : 202