Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Active Directory objects may not be replicated from the restored server after an authoritative restore on a Windows Server 2003-based domain controller


View products that this article applies to.

Symptoms

Consider the following scenario.
  • On a Windows Server 2003-based domain controller, you run an Active Directory domain. Or, you run an Active Directory Application Mode (AD/AM) instance.
  • You find that some objects are missing. Or, you find that you have incorrect data.
  • A recent backup contains the missing information about these objects.
  • You restore the database, and you perform an authoritative restore for these objects.
After the server replicates, you find that objects are still missing from other replicas of the naming context. Or, you find that data for these objects is still incorrect on other replicas of the naming context. However, these objects are not missing on the restored server. Also, the data for these objects is correct on the restored server.

The following events are logged in the Directory Services log on the Windows Server 2003-based domain controller.

Event 1

Event ID : 1173
Category : Internal Processing
Source : NTDS
General Type : Warning
Message : Internal event: Active Directory has encountered the following exception and associated parameters.
Exception: e0010002
Parameter: 170ff94
Additional Data Error value: 8442
Internal ID: 10309cb

Note In this event, the value of the Internal ID entry may differ slightly depending on the version of the Ntdsa.dll file on the server. Also, the value of the Parameter entry may differ slightly depending on the server replication progress.

Event 2

Event ID : 1699
Category : Replication
Source : NTDS Replication
Type : Error
Message : The local domain controller failed to retrieve the changes requested for the following directory partition. As a result, it was unable to send the change requests to the domain controller at the following network address.
Directory partition: NC name
Network address: guid-based DC name
Extended request code: 0
Additional Data
Error value: 8442 The replication system encountered an internal error.

↑ Back to the top


Cause

This problem occurs when the update sequence number (USN) recalculation yields incorrect results.

After a database restoration, a server changes the replication identity. The server recalculates the USNs that it uses to start the replication process with the existing domain controllers in the forest. Under certain circumstances, the USN recalculation may yield incorrect results. Therefore, the replication does not work.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 installed.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix replaces hotfix 937855.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with SP1, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Ntdsa.dll5.2.3790.30881,524,22411-Feb-200821:11x86SP1
W03a2409.dll5.2.3790.308829,69608-Feb-200816:21x86SP1
Windows Server 2003 with SP2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ntdsa.dll5.2.3790.42331,525,24811-Feb-200820:57x86
Windows Server 2003 with SP1, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdsa.dll5.2.3790.30884,257,79211-Feb-200819:03IA-64SP1Not applicable
W03a2409.dll5.2.3790.308828,67211-Feb-200819:03IA-64SP1Not applicable
Wntdsa.dll5.2.3790.30881,524,22411-Feb-200819:03x86SP1WOW
Ww03a2409.dll5.2.3790.308829,69611-Feb-200819:03x86SP1WOW
Windows Server 2003 with SP2, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdsa.dll5.2.3790.42334,259,84011-Feb-200819:07IA-64SP2Not applicable
Wntdsa.dll5.2.3790.42331,525,24811-Feb-200819:07x86SP2WOW
Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdsa.dll5.2.3790.30872,968,57608-Feb-200807:03x64SP1Not applicable
W03a2409.dll5.2.3790.308730,20808-Feb-200807:03x64SP1Not applicable
Wntdsa.dll5.2.3790.30871,524,22408-Feb-200807:03x86SP1WOW
Ww03a2409.dll5.2.3790.308729,69608-Feb-200807:03x86SP1WOW
Windows Server 2003 with SP2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdsa.dll5.2.3790.42322,970,11208-Feb-200816:42x64SP2Not applicable
Wntdsa.dll5.2.3790.42321,525,24808-Feb-200816:43x86SP2WOW

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

When a domain controller is affected by this problem, you must remove it from the forest or restore it again. Then, make sure that you start the Active Directory replication process with the hotfix installed. Otherwise, the domain controller will experience the same problem again.

To recover the domain controller when this problem occurs, follow these steps:
  1. Restore the system state on the Windows Server 2003-based domain controller.

    Note You do not have to restart the domain controller after this step.
  2. Run an authoritative restore for the objects in the database as needed.
  3. Restart domain controller into DS Restore mode again.

    Note This step is very important. In this step, files that are replaced by the system state backup are being used.
  4. Apply this hotfix, and then restart domain controller in normal mode.
To restore the database, make sure that this hotfix is installed on all the domain controllers that are frequently backed up and that are the primary servers. After you install this hotfix, the system state backup will simplify failure recovery.

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbpubtypekc, kbqfe, kbhotfixserver, KB943576

↑ Back to the top

Article Info
Article ID : 943576
Revision : 5
Created on : 4/10/2008
Published on : 4/10/2008
Exists online : False
Views : 233