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When the Kerberos ticket expires for a Kerberos-authenticated SMB connection that is created to a Windows Server 2003-based server, the oplock on a file cannot be broken in a timely manner


View products that this article applies to.

Symptoms

Consider the following scenario:
  • A client creates a server message block (SMB) connection to a Windows Server 2003-based server by using the Kerberos version 5 authentication protocol.
  • A file is open over this SMB connection. An opportunistic lock (oplock) is set on the file.
  • After a long idle time, the Kerberos ticket expires.
In this scenario, the server tries to break the oplock. However, a long delay occurs before the oplock is eventually broken on the server. Additionally, the client receives a "status_network_session_expired" error.

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Cause

The server sends a request to the client to break the oplock. Then, the client responds to this request. The server returns the "status_network_session_expired" error instead of processing the client response, because the session has already expired. However, the client cannot reauthenticate with the server. In this situation, the server has to wait a long time for the oplock to time out.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Srv.sys5.2.3790.3076361,47222-Jan-200811:08x86
Windows Server 2003 with Service Pack 2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Srv.sys5.2.3790.4222358,40022-Jan-200811:18x86
Windows Server 2003 with Service Pack 1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Srv.sys5.2.3790.30761,110,52822-Jan-200815:56IA-64
Windows Server 2003 with Service Pack 2, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Srv.sys5.2.3790.42221,111,04022-Jan-200816:18IA-64
Windows Server 2003 with Service Pack 1, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Srv.sys5.2.3790.3076674,30422-Jan-200815:49x64
Windows Server 2003 with Service Pack 2, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Srv.sys5.2.3790.4222647,68022-Jan-200816:19x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Workaround

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
To work around this problem, reduce the oplock break time-out value to less than 35 seconds to reduce the time that the server waits before it breaks an oplock. However, you must be very careful when you use this workaround, because this workaround may cause negative effects, such as loss of cached data, depending on your environment.

To change the oplock break time-out value, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
  3. Use one of the following options, as appropriate for your situation:
    1. If the OplockBreakWait registry entry is available under the Parameters subkey, go to step 5.
    2. If the OplockBreakWait registry entry is not available, you must create this entry. To do this, right-click the Parameters subkey, point to New, and then click DWORD Value.
  4. Type OplockBreakWait, and then press ENTER.
  5. Right-click OplockBreakWait, and then click Modify.
  6. In the Value data box, type an appropriate value, and then click OK.
  7. Exit Registry Editor.
  8. Restart the computer.
Note The OplockBreakWait registry entry specifies the time that the server waits for a client to respond to an oplock break request. By default, the server waits 35 seconds before it breaks an oplock by force. You can specify a lesser value for this registry entry to reduce the wait time. However, a shorter wait time may potentially cause loss of cached data. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
296264 Configuring opportunistic locking in Windows

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseinter, kbwinserv2003postsp2fix, kbbug, kbfix, kbhotfixserver, kbqfe, KB943459

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Article Info
Article ID : 943459
Revision : 2
Created on : 7/13/2009
Published on : 7/13/2009
Exists online : False
Views : 532