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Error message when you run code to transfer a BLOB type field to another BLOB type field in Microsoft Dynamics NAV: "Run-time error '10020': C/FRONT Fatal Error: Data conversion error"


View products that this article applies to.

Microsoft Business Solutions-Navision 4.0 and Microsoft Navision 4.0 are now part of Microsoft Dynamics NAV 4.0. All references to Microsoft Business Solutions-Navision or to Microsoft Navision 4.0 relate to Microsoft Dynamics NAV.

This article applies to Microsoft Dynamics NAV for all countries and all language locales.

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Symptoms

When you run code that contains the CFront.AssignField object to transfer a binary large object (BLOB) type field to another BLOB type field, you receive the following error message:
Run-time error '10020': C/FRONT Fatal Error: Data conversion error.
This problem occurs in the following products:
  • Microsoft Dynamics NAV 5.0
  • Microsoft Dynamics NAV 4.0

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Cause

This problem occurs because the internal handling of complex data types cannot handle the conversion between two BLOB type fields.

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Resolution

A supported hotfix is now available from Microsoft. The hotfix corrects the problem that is described in this article. Apply the hotfix only to systems that are experiencing this specific problem.

To resolve this problem immediately, contact Technical Support for Microsoft Dynamics and related products to obtain the hotfix. You can log on to the Microsoft Dynamics site and create a new support request. To do this, visit the following Microsoft Web site: You can also contact Technical Support for Microsoft Dynamics and related products by telephone at (888) 477-7877.

Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Technical Support Professional for Microsoft Dynamics and related products determines that a specific update will resolve your problem. The usual support costs will apply to any additional support questions and issues that do not qualify for the specific update in question.


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How to obtain the Microsoft Dynamics NAV hotfix or update files

After you request a Microsoft Dynamics NAV hotfix or an update file from Technical Support for Microsoft Dynamics, a hyperlink will be sent to you in an e-mail.


The e-mail will contain a hyperlink and a password. You can use the hyperlink to download the Microsoft Dynamics NAV hotfix or the update files. When you click the hyperlink, the File Download – Security Warning dialog box opens. Then, you are prompted to run, to save, or to cancel the download.


If you click Run, the files start the download and the extraction process. You must specify a folder for the new files, and then provide the password.


If you click Save, you must specify a path for saving the compressed file. When you open the file that you saved, you are prompted to specify a path for the files. You must then provide the password provided in the e-mail.


If you click Cancel, the download process stops.

How to install a Microsoft Dynamics NAV hotfix or an update file

The Microsoft Dynamics NAV platform hotfixes and updates are made available as single files. To apply a Microsoft Dynamics NAV hotfix or an update, you must replace the existing Microsoft Dynamics NAV installation files with the hotfix or update files.

File information

The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Cfront.dll5.0.0.255331,242,23211-Nov-200723:44x86
Cfront.ocx5.0.25533.0148,60011-Nov-200723:43x86
Cfrontsql.dll5.0.25533.01,369,20811-Nov-200723:44x86

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Status

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbhotfixserver, kbqfe, kbmbsdevelopmenttools, kberrmsg, kbnav50presp1fix, kbmbsmigrate, kb, kbmbspartner

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Article Info
Article ID : 943332
Revision : 2
Created on : 1/31/2017
Published on : 1/31/2017
Exists online : False
Views : 324