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Error message when you install the Microsoft Dynamics CRM client for Outlook or the Microsoft Dynamics CRM server: "Action Microsoft.Crm.Setup.Common.InstallHelpIndexesAction failed"


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Symptoms

You install one of the following programs:
  • The Microsoft Dynamics CRM client for Microsoft Office Outlook
  • The Microsoft Dynamics CRM server
After you install the program, you receive the following error message:
Action Microsoft.Crm.Setup.Common.InstallHelpIndexesAction failed.
You can safely ignore this error message. If you ignore the error message, the installation can be completed. However, the search function of Help is unavailable in the Microsoft Dynamics CRM client for Outlook and in the Microsoft Dynamics CRM server. Additionally, the following error messages are logged in the Crm30clientsetup.log file or in the Crm40srvsetup.log file.

Note The CRM30clientsetup.log file and the Crm40srvsetup.log file are located in the following folder:
C:\Documents and Settings\username\Application Data\Microsoft\MSCRM\Logs
Error message 1
Time| Error| Exception occurred during Help Indexes Installation:
System.Runtime.InteropServices.COMException (0x8000FFFF): Catastrophic Failure at Microsoft.Crm.Tools.ISWrapper.AdminIndexServerClass.GetCatalogByName(String bstrCatalogName)
at Microsoft.Crm.Setup.Common.InstallHelpIndexesAction.InstallHelpIndexes(IDictionary parameters)

Error message 2
Time| Error| System.Exception:
at Microsoft.Crm.Setup.Common.InstallHelpIndexesAction. ---> System.Exception: If you ignore this error, the option to search Help will not be available.
at Microsoft.Crm.Setup.Common.InstallHelpIndexesAction.Do(IDictionary parameters)
at Microsoft.Crm.Setup.Common.Action.ExecuteAction(Action action, IDictionary parameters, Boolean undo)

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Cause

This problem occurs because the Setup program of the Microsoft Dynamics CRM client for Outlook or the Setup program of the Microsoft Dynamics CRM server cannot create the Microsoft Dynamics CRM Help catalog in the indexing service.

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Resolution

To resolve this problem, create the Microsoft CRM Help catalog in the indexing service after you ignore the error message. To do this, follow these steps:
  1. Add the indexing service to the Microsoft Management Console (MMC). To do this, follow these steps:
    1. Click Start, click Run, type MMC, and then click OK.
    2. On the File menu, click Add/Remove Snap-in.
    3. Click Add.
    4. Click Indexing Service, and then click Add.
    5. Click Local Computer, click Finish, and then click OK.
  2. Add the Microsoft CRM Help catalog to the indexing service. To do this, follow these steps:
    1. Expand Indexing Service on Local Machine, and then verify that no Microsoft CRM Help catalog exists.
    2. Right-click Indexing Service on Local Machine, point to New, and then click Catalog.
    3. In the Add Catalog dialog box, type Microsoft CRM Help in the Name box.
    4. Click Browse.
    5. In the Location box, type one of the following locations, depending on the program that you want to install:

      • The location of the application files for the Microsoft Dynamics CRM client for Outlook

        Note By default, the application files for the Microsoft Dynamics CRM client for Outlook are located in the following folder:
        C:\Program Files\Microsoft CRM\Client\ApplicationFiles
      • The location of the application files for the Microsoft Dynamics CRM server

        Note By default, the application files for the Microsoft Dynamics CRM server are located in the following folder:
        C:\Program Files\MSCRM\Server\Application
    6. Click OK.
    7. Right-click Indexing Services on Local Computer, and then click Stop.
    8. Right-click Indexing Services on Local Computer, and then click Start.
  3. If you install Microsoft Dynamics CRM 4.0, add the Microsoft Dynamics CRM content directory to the Microsoft CRM Help catalog. To do this, follow these steps:
    1. Right-click Microsoft CRM Help, point to New, and then click Directory.
    2. In the Add Dictionary dialog box, click Browse, and then type the path of the content directory in the Path box.

      Note By default, the content directory is located in the following folder:
      C:\Program Files\MSCRM\CRMWeb\Help
    3. Leave the Alias (UNC) box blank.
    4. In the Include in Index area, click Yes.
  4. Add the PRO content directory to the Microsoft CRM Help catalog. To do this, follow these steps:
    1. Right-click Microsoft CRM Help, point to New, and then click Directory.
    2. In the Add Dictionary dialog box, click Browse, and then type the path of the PRO content directory in the Path box.

      Note By default, the PRO content directory is located in the following folder:
      C:\Program Files\Microsoft CRM\Client\Res\Web\Help\PRO\Content
    3. Leave the Alias (UNC) box blank.
    4. In the Include in Index area, click Yes.
  5. Add the SBE content directory to the Microsoft CRM Help catalog. To do this, follow these steps:
    1. Right-click Microsoft CRM Help, point to New, and then click Directory.
    2. In the Add Dictionary dialog box, click Browse, and then type the path of the SBE content directory in the Path box.

      Note By default, the SBE content directory is located in the following folder:
      C:\Program Files\Microsoft CRM\Client\Res\Web\Help\SBE\Content
    3. Leave the Alias (UNC) box blank.
    4. In the Include in Index area, click Yes.
  6. Restart the indexing service. To do this, follow these steps:
    1. Right-click Indexing Services on Local Computer, and then click Stop.
    2. Right-click Indexing Services on Local Computer, and then click Start.

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Keywords: KB943004, kbmbsinstallation, kbexpertisebeginner, kbexpertiseinter, kbmbsmigrate, kbprb, kbtshoot, kberrmsg

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Article Info
Article ID : 943004
Revision : 4
Created on : 2/28/2008
Published on : 2/28/2008
Exists online : False
Views : 418