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The NTBackup.exe tool stops responding if there are lots of registry entries under the FilesNotToBackup subkey on a Windows Server 2003-based computer


View products that this article applies to.

Symptoms

Consider the following scenario:
  • On a Windows Server 2003-based computer, you use the Backup tool (NTBackup.exe) to perform a backup.
  • This backup does not include the system state data.
In this scenario, the backup process stops responding when the following status message is displayed:
Preparing to back up using shadow copy...
Therefore, you cannot complete the backup. Additionally, the following event may be logged in the Application log:

Event Type: Error
Event Source: Application Hang
Event Category: (101)
Event ID: 1002
Date: <Date>
Time: <Time>
User: N/A
Computer: <Computer name>
Description:
Hanging application ntbackup.exe, version 5.2.3790.3959, hang module hungapp, version 0.0.0.0, hang address 0x00000000.

This problem occurs if the registry entries under the following subkey total more than 65,536 characters:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\BackupRestore\FilesNotToBackup
This situation typically occurs when there are lots of registry entries under the FilesNotToBackup subkey. In a typical scenario, these registry entries are generated by the Distributed File System Replication (DFSR) service.

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Cause

This problem occurs because the NTBackup.exe tool incorrectly indexes registry entries under the FilesNotToBackup subkey. If there are too many registry entries exist under the FilesNotToBackup subkey, this may trigger an overflow situation.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 installed. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Ntbackup.exe5.2.3790.30221,229,31209-Oct-200712:41x86SP1
W03a2409.dll5.2.3790.295728,67218-Jun-200704:31x86SP1
Windows Server 2003 with Service Pack 2, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Ntbackup.exe5.2.3790.41661,229,31209-Oct-200713:39x86SP2
W03a3409.dll5.2.3790.410713,82429-Jun-200707:28x86SP2
Windows Server 2003 with Service Pack 1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntbackup.exe5.2.3790.30223,589,63210-Oct-200704:38IA-64SP1Not applicable
W03a2409.dll5.2.3790.295727,64810-Oct-200704:38IA-64SP1Not applicable
Ww03a2409.dll5.2.3790.295728,67210-Oct-200704:38x86SP1WOW
Windows Server 2003 with Service Pack 2, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntbackup.exe5.2.3790.41663,590,14410-Oct-200705:01IA-64SP2Not applicable
W03a3409.dll5.2.3790.410712,80010-Oct-200705:01IA-64SP2Not applicable
Ww03a3409.dll5.2.3790.410713,82410-Oct-200705:01x86SP2WOW
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntbackup.exe5.2.3790.30221,964,03210-Oct-200704:38x64SP1Not applicable
W03a2409.dll5.2.3790.295729,18410-Oct-200704:38x64SP1Not applicable
Ww03a2409.dll5.2.3790.295728,67210-Oct-200704:38x86SP1WOW
Windows Server 2003 with Service Pack 2, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntbackup.exe5.2.3790.41661,966,59210-Oct-200705:00x64SP2Not applicable
W03a3409.dll5.2.3790.410714,33610-Oct-200705:00x64SP2Not applicable
Ww03a3409.dll5.2.3790.410713,82410-Oct-200705:00x86SP2WOW

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseinter, kbwinserv2003postsp2fix, kbbug, kbfix, kbHotfixServer, kbqfe, KB942843

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Article Info
Article ID : 942843
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 295