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Some cases are still reparented when an account is reassigned even if the cascade behavior is set to Cascade None in Microsoft Dynamics CRM 3.0


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Source: Microsoft Support

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Symptoms

Consider the following scenario in Microsoft Dynamics CRM 3.0.
  • The cascade behavior for the account - case relationship is set to Cascade None.
  • You change the ownership of an account.
In this scenario, some cases that are associated with the account transfer the ownership to the new owner. However, other cases keep the original owner.

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Cause

This problem occurs because the following relationship links to the Case entity:
  • Account - Case
  • Contact - Case
Both relationships must have the cascade behavior set to Cascade None.

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Resolution

To resolve this problem, set the cascade behavior of the Contact - Case Parental relationship to Cascade None. To do this, follow these steps:
  1. Click Settings, click Customization, and then click Customize Entities.
  2. Double-click Contact, click Relationships, and then double-click the Contact - Case Parental relationship.
  3. Set the Type of Behavior value to Configurable Cascading.
  4. Set the cascade behavior for Reparent to Cascade None.
  5. Click Save and Close.
  6. Click Actions, and then click Publish.

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More information

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
923818� Changes to the Type of Behavior option in a relationship entity are not saved after you import customizations in Microsoft Dynamics CRM 3.0
933423� Behavior settings for a relationship are ignored in Microsoft Dynamics CRM 3.0

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Keywords: KB942683, kbexpertiseinter, kbmbsmigrate, kbexpertisebeginner, kbnomt, kbprb, kbtshoot, kbexpertiseadvanced, kbmbsservice

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Article Info
Article ID : 942683
Revision : 3
Created on : 2/22/2008
Published on : 2/22/2008
Exists online : False
Views : 336