Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: You may experience problems when you use a Windows Communication Foundation (WCF) adapter in Microsoft BizTalk Server 2006 R2


View products that this article applies to.

Symptoms

When you use a Microsoft Windows Communication Foundation (WCF) adapter in Microsoft BizTalk Server 2006 R2, you may experience one of the following problems.

Problem 1

When you use custom binding for an outgoing process, the WCF adapter does not pass the namespace information. Therefore, when you call the writeStartElement method to write a start tag to an XML file, the start tag of the XML file is not associated with any namespace.

Problem 2

The WCF adapter produces incorrect data if the following conditions are true:
  • The send port of the WCF adapter uses a template message that uses string encoding.
  • The size of the template message is larger than 4 KB.
  • The template message uses the non-UTF8 encoding.

Problem 3

The WCF adapter does not follow the transaction time-out setting in the Machine.config file. The WCF adapter has a maximum transaction time-out setting of 60 minutes. The transaction time-out setting is not changed even if the transaction time-out setting in the Machine.config file is more than 60 minutes.

↑ Back to the top


Cause

These problems occur because of bugs in the Microsoft.BizTalk.Adapter.Wcf.Runtime.dll assembly.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have BizTalk Server 2006 R2 installed to apply this hotfix.

Restart information

You do not have to restart the computer after you apply this hotfix.

Registry information

You do not have to change the registry.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

This hotfix contains only those files that are required to correct the issues that this article lists. This hotfix may not contain all the files that you must have to fully update a product to the latest build.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Microsoft.biztalk.adapter.wcf.runtime.dll3.6.1413.2209,98427-Sep-200709:19x86
Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

The problems that are described in the "Symptoms" section are fixed in the hotfix as follows.

Problem 1

The code is changed so that the namespace information is passed to the writeStartElement method.

Problem 2

The message encoding from the byte order mark (BOM) is detected when the adapter constructs the adapter message stream from the BizTalk Server message stream.

Problem 3

The system time-out setting is used for the WCF adapter time-out setting. The default value of the system time-out setting is 10 minutes. This value can be changed by modifying the Machine.config file. For example, you can modify the following section in the Machine.config file to change the time-out setting to 15 minutes.
<configuration>
 <system.transactions>
   <machineSettings maxTimeout="00:15:00" />
 </system.transactions>
</configuration>
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbbtsadapters, kbbiztalk2006r2sp1fix, kbexpertiseadvanced, kbfix, kbqfe, kbHotfixServer, kbautohotfix, KB942612

↑ Back to the top

Article Info
Article ID : 942612
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 497