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You experience slow performance when you search for a Microsoft Knowledge Base article in Microsoft Dynamics CRM 3.0


View products that this article applies to.

Symptoms

Consider the following scenario. You restart the Microsoft SQL Server 2005 server for Microsoft Dynamics CRM 3.0. Then, you search for a Knowledge Base article. In this scenario, you experience slow performance. When this problem occurs, Microsoft Dynamics CRM 3.0 takes a long time to return a result. Additionally, if the SQL time-out value is extended, you receive a SQL time-out error message that resembles the following error message:
Timeout expired.

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Cause

This problem occurs because the DocumentIndex table contains the full-text index for the Microsoft Dynamics CRM Knowledge Base articles. The full-text index query causes a known issue in SQL Server 2005.

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Resolution

To resolve this problem, use one of the following methods.

Method 1

Add the following registry subkeys to increase the time-out values:
  • OLEDBTimeout
  • ExtendedTimeout
To do this, see "Method 1" in Microsoft Knowledge Base (KB) article 918609.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
918609� A time-out occurs when you import large customization files into Microsoft Dynamics CRM

Method 2

Turn off signature verification. To do this, use the workaround that is described in Microsoft Knowledge Base article 915850.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
915850� You may experience a 45-second delay when you run a full-text query in an instance of SQL Server 2005 that is running on a server without Internet access

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Keywords: KB942597, kbexpertiseinter, kbprb, kbmbsmigrate, kbtshoot, kbexpertisebeginner, kbmbsservice, kberrmsg

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Article Info
Article ID : 942597
Revision : 3
Created on : 2/27/2008
Published on : 2/27/2008
Exists online : False
Views : 404