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A 32-bit application cannot access the system32 folder on a computer that is running a 64-bit version of Windows Server 2003 or of Windows XP


View products that this article applies to.

Symptoms

On a computer that is running a 64-bit version of Windows Server 2003 or of Windows XP, a 32-bit application cannot access the following folder:
%WinDir%\System32
Therefore, the 32-bit application cannot start any 64-bit applications in the System32 folder. Additionally, the 32-bit application cannot retrieve file information about any files in the System32 folder or in the subfolders of the System32 folder.

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Cause

This behavior occurs because Windows on Windows 64-bit (WOW64) provides file system redirection. In a 64-bit version of Windows Server 2003 or of Windows XP, the %WinDir%\System32 folder is reserved for 64-bit applications. When a 32-bit application tries to access the System32 folder, access is redirected to the following folder:
%WinDir%\SysWOW64
By default, file system redirection is enabled.

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Resolution

After you install the following hotfix, a 32-bit application can access the following native system folder instead of the %WinDir%\System32 folder:
%WinDir%\Sysnative
WOW64 recognizes the Sysnative folder as a special alias. Therefore, the file system does not redirect access away from the Sysnative folder. This mechanism is flexible and easy to use. You can use the Sysnative folder to bypass file system redirection.

Note After you apply this hotfix, you must append the %WinDir%\Sysnative path to the %path% environment variable. To do this, run the following command at a command prompt:
set path=%path%;%WinDir%\Sysnative

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Wow64.dll5.2.3790.3013496,64024-Sep-200705:18IA-64
Windows Server 2003 with Service Pack 2, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Wow64.dll5.2.3790.4156496,64024-Sep-200706:02IA-64
Windows Server 2003 or Windows XP, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Wow64.dll5.2.3790.3013249,34422-Sep-200709:02x64
Windows Server 2003 or Windows XP with Service Pack 2, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Wow64.dll5.2.3790.4156249,34422-Sep-200709:10x64

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Workaround

To work around this behavior, use one of the following methods.

Method 1

Create an NTFS junction point that points to the %WinDir%\System32 folder. Access the NTFS junction point instead of the %WinDir%\System32 folder.

Method 2

You can use the following functions to control file system redirection.
  • Wow64DisableWow64FsRedirection
  • Wow64EnableWow64FsRedirection
  • Wow64RevertWow64FsRedirection
For more information, visit the following Microsoft Web site:

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseinter, kbwinserv2003postsp2fix, kbbug, kbfix, kbHotfixServer, kbqfe, KB942589

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Article Info
Article ID : 942589
Revision : 4
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 478