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When you connect to a Windows Server 2003-based computer in a terminal server session, the remote computer may stop responding if it has East Asian languages installed


View products that this article applies to.

Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows

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Symptoms

Consider the following scenario. You connect to a Windows Server 2003-based computer in a terminal server session. The Windows Server 2003-based computer has East Asian languages installed. In this scenario, the terminal server session may stop responding. Additionally, many system-wide functions on the Windows Server 2003-based computer may eventually stop responding. For example, Task Manager and Windows Management Instrumentation (WMI) may stop responding.

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Cause

This problem may occur because the font management module in the Win32k.sys driver does not correctly handle the ordering of fonts for East Asian languages.

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Workaround

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk. To work around this problem, you must reorder the font list for each base font so that all the font lists are in the same order. The base font information is saved in the registry entries under the following subkey:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontLink\SystemLink
To do this, make sure that the multiple values in each REG_MULTI_SZ registry entry under the SystemLink subkey are in alphabetical order. For example, you may have the following registry entries under the SystemLink subkey. The multiple values in these registry entries are not ordered correctly.

Registry entry: Tahoma

Value:
MSGOTHIC.TTC,MS UI Gothic
gulim.ttc,gulim
SimSun.TTC,SimSun
Registry entry: Microsoft Sans Serif

Value:
MSGOTHIC.TTC,MS UI Gothic
SimSun.TTC,SimSun
mingliu.ttc,PMingLiU
gulim.ttc,gulim
In this situation, sort the multiple values alphabetically, as follows.

Registry entry: Tahoma

Value:
gulim.ttc,gulim
MSGOTHIC.TTC,MS UI Gothic
SimSun.TTC,SimSun
Registry entry: Microsoft Sans Serif

Value:
gulim.ttc,gulim
mingliu.ttc,PMingLiU
MSGOTHIC.TTC,MS UI Gothic
SimSun.TTC,SimSun

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kbexpertiseinter, kbtshoot, kbprb, KB942490

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Article Info
Article ID : 942490
Revision : 3
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 200