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FIX: Event ID: 1723 occurs when you use Adapters for Enterprise Applications together with BizTalk Server 2006 or BizTalk Server 2006 R2 to process lots of messages


View products that this article applies to.

Symptoms

When you use the BizTalk Server Adapters for Enterprise Applications (also known as the Line of Business Adapters) together with Microsoft BizTalk Server 2006 or Microsoft BizTalk Server 2006 R2 to process lots of messages, the following error messages may be logged in the Application log:
Error message 1

Event Type: Error
Event Source: Microsoft Biztalk Adapters for Enterprise Applications
Event Category: None
Event ID: 0
Description:
Error transmitting message: Exception encrypting: Encryption failed with error code: 1723.

Error message 2

Event Type: Error
Event Source: Microsoft Biztalk Adapters for Enterprise Applications
Event Category: None
Event ID: 0
Description:
Runtime Error : Exception encrypting: Encryption failed with error code: 1723.

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Cause

This problem occurs because the adapters call the Windows CryptProtectData method. However, the CryptProtectData method is not intended for high volume throughput. Additionally, the method handles a maximum of 10 concurrent calls. When the adapters process lots of messages, the adapters may try to make more than 10 concurrent calls to the CryptProtectData method. When this behavior occurs, a failure occurs.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Microsoft BizTalk Server 2006 and Microsoft BizTalk Adapters for Enterprise Applications installed to apply the hotfix for BizTalk Server 2006. You must have Microsoft BizTalk Server 2006 R2 and Microsoft BizTalk Adapters for Enterprise Applications installed to apply the hotfix for BizTalk Server 2006 R2.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For BizTalk Server 2006


File nameFile versionFile sizeDateTimePlatform
Btcore.dll1.0.1101.02,131,45628-Sep-200715:37x86
Microsoft.biztalk.adapters.bizutil.dll1.0.1101.0164,40828-Sep-200715:36x86

For BizTalk Server 2006 R2


File nameFile versionFile sizeDateTimePlatform
Btcore.dll1.0.5017.02,131,45631-Jul-200815:31x86
Microsoft.biztalk.adapters.bizutil.dll1.0.5017.0164,40831-Jul-200815:29x86

Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

Installation Notes
  1. When you request this hotfix download from the Microsoft Support site, click "Show additional information" on the Hotfix Request page to show more columns of information related to the two hotfixes. The hotfix with Build number 1.00.5017.00 is for BizTalk Server 2006 R2, and the hotfix with build number 1.00.1101.00 is for BizTalk Server 2006.
  2. If you are using Microsoft BizTalk Server 2006 R2, and you receive error "Error occurred during initialization of VM" when you use BizTalk Adapter for JD Edwards EnterpriseOne, download and apply the hotfix that is described in the following Microsoft Knowledge Base article:
    974617 FIX: Error message when you use BizTalk Adapter for JD Edwards EnterpriseOne in BizTalk Server: "Error occurred during initialization of VM"

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

When this problem occurs, the message is retried according to the retry settings for the adapter port. By default, the message is retried after five minutes, and the maximum number of retries is three. Typically, the message succeeds on the first retry. After you apply this hotfix, you do not receive the error messages that are mentioned in the "Symptoms" section.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

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Keywords: kbbiztalk2006presp1fix, kbautohotfix, kbbtsadapters, kbexpertiseinter, kbhotfixserver, kbqfe, KB942419

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Article Info
Article ID : 942419
Revision : 3
Created on : 11/11/2009
Published on : 11/11/2009
Exists online : False
Views : 569