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Event 1008 is logged in the Application log after you uninstall the Quality of Service Packet Scheduler service on a Windows Server 2003-based computer


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Symptoms

When you uninstall the Quality of Service (QoS) Packet Scheduler service, and then you try to add performance counters in the performance monitor on a Windows Server 2003-based computer, the following event is logged in the Application log:

Event Type: Error
Event Source: Perflib
Event Category: None
Event ID: 1008
Date: <Date>
Time: <Time>
User: N/A
Computer: <Computer Name>
Description: The Open Procedure for service "PSched" in DLL "C:\WINDOWS\system32\pschdprf.dll" failed. Performance data for this service will not be available. The Status code returned is the first DWORD in the attached data. Data: 0000: 02 00 00 00

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Cause

This problem occurs because the system removes the Pschdprf.dll file but does not remove the following registry values when the QoS Packet Scheduler is removed:
  • HKEY_LOCAL_MACHINESystem\CurrentControlSet\Services\Psched\Performance\Libray
  • HKEY_LOCAL_MACHINESystem\CurrentControlSet\Services\Psched\Performance\Open
  • HKEY_LOCAL_MACHINESystem\CurrentControlSet\Services\Psched\Performance\Open
  • HKEY_LOCAL_MACHINESystem\CurrentControlSet\Services\Psched\Performance\Collection
When you add a performance counter, the performance monitor tries to load the Pschdprf.dll file because these registry values exist. Event 1008 is logged because the Pschdprf.dll file does not exist.

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Workaround

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To work around this problem, manually remove the following registry entries:
  • HKEY_LOCAL_MACHINESystem\CurrentControlSet\Services\Psched\Performance\Libray
  • HKEY_LOCAL_MACHINESystem\CurrentControlSet\Services\Psched\Performance\Open
  • HKEY_LOCAL_MACHINESystem\CurrentControlSet\Services\Psched\Performance\Open
  • HKEY_LOCAL_MACHINESystem\CurrentControlSet\Services\Psched\Performance\Collection

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: KB942393, kbexpertiseinter, kberrmsg, kbtshoot

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Article Info
Article ID : 942393
Revision : 4
Created on : 9/21/2007
Published on : 9/21/2007
Exists online : False
Views : 331