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The RFID Print Wizard may appear to stop responding when Tag Printed Notifications are displayed in BizTalk Server 2006 R2


View products that this article applies to.

Symptoms

In Microsoft BizTalk Server 2006 R2, the RFID Print Wizard may appear to stop responding (hang) when Tag Printed Notifications are displayed.

When this issue occurs, the information in the RFID services log file and in the Provider log file may indicate that all tags were printed as expected.

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Cause

This issue may occur if the printing speed of the RFID printer is faster than the value for the maxTagPrintedEvent property in the RFID server configuration.

Note The value for the maxTagPrintedEvent property is the maximum number of print notifications per second that the RFID service can receive. The default value for the maxTagPrintedEvent property is 50.

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Resolution

To resolve this issue, use the SetServerConfiguration method to increase the number of print notifications per second that the RFID service can receive. For example, consider the following sample code.
ServerManagerProxy smp = new ServerManagerProxy(hostname);
     RfidServerConfiguration config = smp.GetServerConfiguration();
     config.RfidServerRuntimeConfiguration.deviceManagerConfiguration.maxTagPrintedEvent = newvalue;
     Smp.SetServerConfiguration(config);
Note The minimum value for the maxTagPrintedEvent property is 30 and the maximum value for the maxTagPrintedEvent property is 500.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

When this issue occurs, the RFID printer has correctly raised the notifications for each tag printed event. However, the printer may raise tag printed events at a faster rate than the value of the maxTagPrintedEvent property. Therefore, the RFID service may be unable to display the notifications for all the tag printed events and some of these notifications may be lost. This behavior may cause the RFID Print Wizard to appear to stop responding. Therefore, it may appear as if some tags have not been printed. However, this is only an issue in RFID Manager. This issue does not affect the actual printing of the tags.

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References

For more information about the SetServerConfiguration method, see the BizTalk RFID Help documentation.

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Keywords: KB942287, kbprb, kbtshoot, kbbts

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Article Info
Article ID : 942287
Revision : 4
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 453