Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

When you open a Web page by typing a File URI in the Windows Internet Explorer 7 Address bar on a Windows Vista-based computer, the query string disappears after the Web page opens


View products that this article applies to.

Symptoms

On a Windows Vista-based computer, you open a Web page by typing a File Uniform Resource Identifier (URI) in the in Windows Internet Explorer 7 Address bar. This File URI contains a query string. However, after the Web page opens, the query string disappears from the Address bar. Additionally, the query is not in the document.location object.

For example, if you open a Web page by typing file:///c:/test.htm?p=1 in the Address bar, the query string disappears from the Address bar after the Web page opens.

This problem also occurs if you run a command at a command prompt to open a Web page on one of the following computers:
  • A Windows XP-based computer that has Internet Explorer 7 installed
  • A Windows Server 2003-based computer that has Internet Explorer 7 installed
For example, this problem also occurs if you run the following command to open the Web page:
iexplore.exe file:///c:/test.htm?p=1

↑ Back to the top


Cause

In Windows Vista, when you type a File URI in the Address bar of a low-rights instance of Internet Explorer 7, Internet Explorer 7 starts a normal-rights instance of Internet Explorer 7 to handle the File URI. To do this, Internet Explorer passes the File URI to the normal-rights instance by using a command line. On the command line, the fragments and queries of the File URI are removed. Therefore, this problem occurs. These fragments and queries of the File URI are also removed if you run a command to open the Web page in Windows XP or in Windows Server 2003.

↑ Back to the top


Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack

Hotfix information

Windows Vista

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
To install the hotfix, you must have Internet Explorer 7 installed.
Restart requirement
You have to restart your computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other previously released hotfixes.
Registry information
To enable this hotfix, follow these steps.

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
  1. Click Start
    , type regedit in the Start Search box, and then press ENTER.
  2. Locate and then click the following registry subkey:
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl
  3. On the Edit menu, point to New, and then click Key.
  4. Type FEATURE_ACCEPT_QUERY_AND_FRAGMENT_OF_CMDLINE_FILE_URI_KB942172, and then press ENTER.
  5. On the Edit menu, point to New, and then click DWORD Value.
  6. Type iexplore.exe, and then press ENTER.
  7. Right-click iexplore.exe, and then click Modify.
  8. Type 1, and then click OK.
  9. On the Edit menu, point to New, and then click DWORD Value.
  10. Type ieuser.exe, and then press ENTER.
  11. Right-click ieuser.exe, and then click Modify.
  12. Type 1, and then click OK.
  13. Exit Registry Editor.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Update.mumNot applicable1,94613-Sep-200712:00Not applicable
X86_22ba0e076db1e980674d602d9f13643d_31bf3856ad364e35_6.0.6000.20679_none_5b03d9056456861a.manifestNot applicable69513-Sep-200712:00Not applicable
X86_microsoft-windows-ieframe_31bf3856ad364e35_6.0.6000.20679_none_63031c04ca46c2a1.manifestNot applicable829,59913-Sep-200712:00Not applicable
Ieframe.dll7.0.6000.206796,066,17613-Sep-200702:13x86
Ieui.dll7.0.6000.20679180,73613-Sep-200702:13x86
Windows Vista, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Amd64_22ba0e076db1e980674d602d9f13643d_31bf3856ad364e35_6.0.6000.20679_none_b72274891cb3f750.manifestNot applicable69713-Sep-200712:00Not applicable
Amd64_2928ddff5b95d9a1bc7cde8dac1094b8_31bf3856ad364e35_6.0.6000.20679_none_e3ce32b301f21e40.manifestNot applicable69913-Sep-200712:00Not applicable
Amd64_microsoft-windows-ieframe_31bf3856ad364e35_6.0.6000.20679_none_bf21b78882a433d7.manifestNot applicable829,70313-Sep-200712:05Not applicable
Package_1_for_kb942172~31bf3856ad364e35~amd64~~6.0.2.0.mumNot applicable1,79413-Sep-200712:00Not applicable
Package_2_for_kb942172~31bf3856ad364e35~amd64~~6.0.2.0.mumNot applicable1,95713-Sep-200712:00Not applicable
Update.mumNot applicable1,86913-Sep-200712:00Not applicable
Ieframe.dll7.0.6000.206797,068,16013-Sep-200703:12x64
Ieui.dll7.0.6000.20679228,35213-Sep-200703:12x64

Windows XP

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
To install the hotfix, you must have Internet Explorer 7 and Windows XP Service Pack 2 installed.
Restart requirement
You have to restart your computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other previously released hotfixes.
Registry information
To enable this hotfix, follow these steps:
  1. Locate and then click the following registry subkey:
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl
  2. On the Edit menu, point to New, and then click Key.
  3. Type FEATURE_ACCEPT_QUERY_AND_FRAGMENT_OF_CMDLINE_FILE_URI_KB942172, and then press ENTER.
  4. On the Edit menu, point to New, and then click DWORD Value.
  5. Type iexplore.exe, and then press ENTER.
  6. Right-click iexplore.exe, and then click Modify.
  7. Type 1, and then click OK.
  8. On the Edit menu, point to New, and then click DWORD Value.
  9. Type ieuser.exe, and then press ENTER.
  10. Right-click ieuser.exe, and then click Modify.
  11. Type 1, and then click OK.
  12. Exit Registry Editor.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP with SP2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Ieframe.dll7.0.6000.206816,066,17618-Sep-200704:10x86

Windows Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
To install the hotfix, you must have Internet Explorer 7 and Windows Server 2003 Service Pack 2 installed.
Restart requirement
You have to restart your computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other previously released hotfixes.
Registry information
To enable this hotfix, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl
  3. On the Edit menu, point to New, and then click Key.
  4. Type FEATURE_ACCEPT_QUERY_AND_FRAGMENT_OF_CMDLINE_FILE_URI_KB942172, and then press ENTER.
  5. On the Edit menu, point to New, and then click DWORD Value.
  6. Type iexplore.exe, and then press ENTER.
  7. Right-click iexplore.exe, and then click Modify.
  8. Type 1, and then click OK.
  9. On the Edit menu, point to New, and then click DWORD Value.
  10. Type ieuser.exe, and then press ENTER.
  11. Right-click ieuser.exe, and then click Modify.
  12. Type 1, and then click OK.
  13. Exit Registry Editor.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with SP2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Ieframe.dll7.0.6000.206816,066,17618-Sep-200704:15x86
Windows Server 2003 with SP2, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ieframe.dll7.0.6000.206817,068,16018-Sep-200702:05x64SP2Not applicable
Wieframe.dll7.0.6000.206816,066,17618-Sep-200702:05x86SP2WOW
Windows Server 2003 with SP2, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ieframe.dll7.0.6000.2068111,708,92818-Sep-200702:09IA-64SP2Not applicable
Wieframe.dll7.0.6000.206816,066,17618-Sep-200702:10x86SP2WOW

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Vista Service Pack 1.

↑ Back to the top


More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: KB942172, kbHotfixServer, kbqfe, kbexpertisebeginner, kbfix, kbvistasp1fix, kbautohotfix

↑ Back to the top

Article Info
Article ID : 942172
Revision : 6
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 481