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FIX: A Business Activity Monitoring (BAM) activity is not rolled back when the send port fails in delivering the output message in BizTalk Server 2006


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You create and deploy a Business Activity Monitoring (BAM) activity.
  • You enable the Enable routing for failed messages option for the corresponding send port of the deployed activity.
  • You receive a message that is generated by the activity in Microsoft BizTalk Server 2006.
  • BizTalk Server 2006 processes the message. However, the send port fails in delivering the output message.
In this scenario, the transaction for BAM is not rolled back as expected. After the output message is sent out, the BAM data contains two entries for the transaction instead of one entry.

Notes
  1. One of the two entries is in the table bam_ActivityName_Active of BAMPrimaryImport database. The other entry is in the bam_ActivityName_Completed table of the BAMPrimaryImport database.
  2. This problem does not occur if you clear the Enable routing for failed messages option for the send port.

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Cause

This problem occurs because of an error in the BizTalk message engine.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problemP1 that P2 described in this article. Apply this hotfix only to systems that are experiencing the problemP1 described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have BizTalk Server 2006 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
x86-based version for Microsoft BizTalk Server 2006
File nameFile versionFile sizeDateTimePlatform
Btshttpreceive.dll3.5.1711.0183,82419-Sep-200720:06x86
Btsmessageagent.dll3.5.1711.0694,28819-Sep-200720:06x86
Btsmsg.dll3.5.1711.0195,07219-Sep-200720:06x86
Btsmsgcore.dll3.5.1711.01,225,22419-Sep-200720:06x86
Microsoft.biztalk.adapter.runtime.dll3.5.1711.083,00019-Sep-200720:06x86
Microsoft.biztalk.epmtransform.dll3.5.1711.019,50419-Sep-200720:06x86
Microsoft.biztalk.globalpropertyschemas.dll3.5.1711.0848,96019-Sep-200720:06x86
Microsoft.biztalk.interop.agent.dll3.5.1711.058,41619-Sep-200720:06x86
Microsoft.biztalk.streaming.dll3.5.1711.054,31219-Sep-200720:06x86
Microsoft.xlangs.basetypes.dll3.5.1711.0103,46419-Sep-200720:06x86
Microsoft.xlangs.biztalk.crossprocess.dll3.5.1711.087,10419-Sep-200720:06x86
Microsoft.xlangs.biztalk.engine.dll3.5.1711.0238,64019-Sep-200720:06x86
Microsoft.xlangs.biztalk.process.dll3.5.1711.066,60819-Sep-200720:06x86
Microsoft.xlangs.bpel.bpelom.dll3.5.1711.0123,94419-Sep-200720:06x86
Microsoft.xlangs.bpel.bpeltranslator.dll3.5.1711.0488,50419-Sep-200720:06x86
Microsoft.xlangs.engine.dll3.5.1711.0259,10419-Sep-200720:06x86
Microsoft.xlangs.runtimetypes.dll3.5.1711.0119,85619-Sep-200720:06x86
Xlangscompiler.dll3.5.1711.01,137,68019-Sep-200720:06x86

x64-based version for Microsoft BizTalk Server 2006
File nameFile versionFile sizeDateTimePlatform
Btshttpreceive.dll3.5.1711.0289,29619-Sep-200720:08x64
Btsmessageagent.dll3.5.1711.01,337,87219-Sep-200720:08x64
Btsmsg.dll3.5.1711.0195,07219-Sep-200720:08x86
Btsmsgcore.dll3.5.1711.01,959,94419-Sep-200720:08x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about how to enable routing for failed messages, visit the following Microsoft Developer Network (MSDN) Web site:
For more information about BAM, visit the following Microsoft Web site:
For more information about failed message routing, visit the following Microsoft Developer Network (MSDN) Web site:

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Keywords: KB942024, kbqfe, kbsurveynew, kbbiztalk2006presp1fix, kbbtsbam, kbexpertiseadvanced, kbautohotfix

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Article Info
Article ID : 942024
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 400