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A Windows Server 2003 x64 Edition-based computer does not automatically restart as expected after the .crash command is executed to generate a dump file


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You use a debugger, such as the WinDbg debugger, to perform a live debugging on a Windows Server 2003 x64 Edition-based computer.
  • You run the .crash command to generate a dump file on this computer.
  • You configure the computer to automatically restart after the debugger collects a complete dump file.
In this scenario, the computer does not automatically restart as expected. Additionally, the debugger stops responding (hangs). Therefore, you must manually shut down the computer to recover.

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Cause

This issue occurs because of a deadlock condition.

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Resolution

The following hotfix is available to resolve this issue.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 2 installed.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with SP2, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Hal.dll5.2.3790.4186280,06412-Nov-200706:30x64SP2
Ntkrnlmp.exe5.2.3790.41864,603,90412-Nov-200706:30x64SP2
Ntoskrnl.exe5.2.3790.41864,534,27212-Nov-200706:30x64SP2

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

This issue has a significant impact if you perform a live debugging when the destination computer is in a remote location.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: KB942004, kbhotfixserver, kbqfe, kbfix, kbexpertiseadvanced, kbautohotfix

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Article Info
Article ID : 942004
Revision : 3
Created on : 11/28/2007
Published on : 11/28/2007
Exists online : False
Views : 257