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A Windows Server 2003�based computer that has an Intel processor may experience high power consumption when the processor is idle and when there is a discontinuity in the C-states that are reported by the BIOS


View products that this article applies to.

Symptoms

A Windows Server 2003�based computer that has an Intel processor may experience high power consumption when the processor is idle. This issue occurs when there is a discontinuity in the C-states that are reported by the computer's BIOS.

For example, consider the following scenario:
  • On a Windows Server 2003-based computer that has an Intel processor, the BIOS reports only the C1 C-state and the C3 C-state. The BIOS does not report the C2 C-state.
  • You let the computer and the processor become idle.
In this scenario, the processor driver does not use the C3 C-state. Instead, the processor remains in the C1 C-state. Therefore, the computer does not exploit the low-power capabilities of the C3 C-state. This issue specifically affects processor power consumption when the processor is idle.

Notes This issue occurs only on computers that are running the following versions of the Windows Server 2003:
  • Windows Server 2003, x86-based versions
  • Windows Server 2003, x64-based versions
This issue does not occur on computers that are running Windows Vista.

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Cause

On a Windows Server 2003-based computer, the Intel processor driver (Intelppm.sys) does not handle discontinuous C-states correctly.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, the computer must be running one of the following operating systems:
  • Windows Server 2003 with Service Pack 1
  • Windows Server 2003 with Service Pack 2
  • Windows XP, x64-based versions
  • Windows XP with Service Pack 2, x64-based versions

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

Registry information

To use one of the hotfixes in this package, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Intelppm.sys5.2.3790.300249,15203-Sep-200708:24x64
Windows Server 2003 with Service Pack 1, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Intelppm.sys5.2.3790.300236,86431-Aug-200714:05x86
Windows Server 2003 with Service Pack 2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Intelppm.sys5.2.3790.414336,86431-Aug-200715:10x86
Windows Server 2003 with Service Pack 2, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Intelppm.sys5.2.3790.414349,15203-Sep-200708:31x64
Windows XP, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Intelppm.sys5.2.3790.300249,15203-Sep-200708:24x64
Windows XP with Service Pack 2, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Intelppm.sys5.2.3790.414349,15203-Sep-200708:31x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about the Intel Nehalem processor, visit the following Intel Web site:
Note If you use Windows Vista, you can visit the following Microsoft Web page for help with power consumption and battery life problems: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseadvanced, kbbug, kbfix, kbhotfixserver, kbqfe, kbpubtypekc, KB941838

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Article Info
Article ID : 941838
Revision : 6
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 283