Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

On a computer that is running an Itanium-based version of Windows Server 2003 and that has hotfix 929413 or hotfix 931308 applied, a 32-bit application may stop unexpectedly when the application raises an exception


View products that this article applies to.

Symptoms

When you run a 32-bit application on a computer that runs an Itanium-based version of Windows Server 2003, the application may stop unexpectedly (crash) when the application raises an exception. For example, Microsoft SQL Server 2005 Management Studio may stop unexpectedly when you try to open a new window in Management Studio.

This problem occurs after you apply hotfix 929413 or hotfix 931308 on the computer. For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
929413� A user dump file may contain incorrect values for some generic registers on an Itanium-based computer that is running Windows Server 2003
931308� You may experience increased paging to the hard disk when you run an SAP R/3 program on a Windows Server 2003-based computer

↑ Back to the top


Cause

Hotfix 929413 changes the registry usage for exception handling. This change conflicts with the WOW64 binary in Windows Server 2003 for Itanium-based systems.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdll.dll5.2.3790.30031,636,86404-Sep-200706:09IA-64SP1Not Applicable
Ntkrnlmp.exe5.2.3790.30036,526,46404-Sep-200706:09IA-64SP1Not Applicable
Wntdll.dll5.2.3790.3003765,95204-Sep-200706:09x86SP1WOW
Windows Server 2003 with Service Pack 2, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdll.dll5.2.3790.41441,636,86404-Sep-200706:14IA-64SP2Not Applicable
Ntkrnlmp.exe5.2.3790.41446,561,28004-Sep-200706:14IA-64SP2Not Applicable
Wntdll.dll5.2.3790.4144766,46404-Sep-200706:14x86SP2WOW

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: KB941796, kbqfe, kbhotfixserver, kbfix, kbbug, kbwinserv2003postsp2fix, kbexpertiseinter, kbautohotfix

↑ Back to the top

Article Info
Article ID : 941796
Revision : 4
Created on : 1/22/2008
Published on : 1/22/2008
Exists online : False
Views : 233