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You cannot log on to a computer in the Windows Server 2003 trusting domain by using a user account in the Windows Server 2003 trusted domain


View products that this article applies to.

Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 (http://support.microsoft.com/kb/322756/) How to back up and restore the registry in Windows

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Symptoms

Consider the following scenario. A Windows Server 2003 domain trusts another Windows Server 2003 domain. You log on to a computer in the trusting domain by using a user account in the trusted domain. However, you may receive the following error message after type the correct user name and password:
The system could not log you on. Please make sure your user name and password are correct
Additionally, the following event may be logged in the System log on some domain controllers:

Event Type: Error
Event Source: NETLOGON
Event Category: None
Event ID: 3224
Date: Date
Time: Time
User: N/A
Computer: ComputerName
Description:
Changing machine account password for account <account> failed with the following error:
There are currently no logon servers available to service the logon request.

This problem occurs every 30 days. This problem stops after a complete replication occurs in the domains.

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Cause

Both domains in a trust relationship share a password. This password is stored in the Trusted Domain Object (TDO) in Active Directory. As part of the account maintenance process, the trusting domain controller changes the password that is stored in the TDO every 30 days. If the changed trust password has not replicated to all domain controllers in an hour, some domain controllers still use the old trust password. Therefore, the authentication fails.

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Resolution

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

By default, domain controllers continue to use the old trust password for an hour after the trust password changes. This one-hour period cannot be configured. After you install this hotfix, you can use a registry entry to configure this period according to the network condition. For more information about how to enable this feature, see the "Registry information" section.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Online Customer Services to obtain the hotfix. To submit an online request to obtain the hotfix, visit the following Microsoft Web site: Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. To create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" section and the online request forms display the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

Registry information

After you apply this hotfix, follow these steps:
1.Click Start, click Run, type regedit, and then click OK.
2.Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\kdc
3. On the Edit menu, point to New, and then click DWORD Value.
4.Type AllowedReplicationLatency, and then press ENTER.
5.Right-click AllowedReplicationLatency, and then click Modify.
6.Under Base, click Decimal.
7.In the Value data box, type the value that you want, and then click OK.

Note The value that you type inside the Value data box is the number of minutes that domain controllers continue to use the old trust password. The default value is 60 minutes. You can adjust this value according to the actual network conditions. For example, domain controllers continue to use the old trust password for 24 hours if you set this value to 1440.
8.Exit Registry Editor.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Kdcsvc.dll5.2.3790.2997220,16025-Aug-200711:26x86
Windows Server 2003 with Service Pack 2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Kdcsvc.dll5.2.3790.4138220,16025-Aug-200710:31x86
Windows Server 2003 with Service Pack 1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Kdcsvc.dll5.2.3790.2997615,42426-Aug-200716:37IA-64
Windows Server 2003 with Service Pack 2, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Kdcsvc.dll5.2.3790.4138615,42426-Aug-200716:43IA-64
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Kdcsvc.dll5.2.3790.2997419,32826-Aug-200716:37x64
Windows Server 2003 with Service Pack 2, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Kdcsvc.dll5.2.3790.4138419,32826-Aug-200716:43x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseinter, kbwinserv2003postsp2fix, kbbug, kbfix, kbhotfixserver, kbqfe, kbpubtypekc, KB941761

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Article Info
Article ID : 941761
Revision : 6
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 250