Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: When you use BizTalk Adapter for MQSeries in BizTalk Server 2006 or in BizTalk Server 2004, the BizTalk application may slow down, and the BizTalk application may eventually stop responding


View products that this article applies to.

Symptoms

In Microsoft BizTalk Server 2006 or in Microsoft BizTalk Server 2004, you use Microsoft BizTalk Adapter for MQSeries to process messages from an IBM MQSeries server. When you do this, the BizTalk application may slow down, and the BizTalk application may eventually stop responding.

↑ Back to the top


Cause

This problem occurs because a memory leak occurs in the default memory heap when you use BizTalk Adapter for MQSeries. This problem occurs when the message that BizTalk Adapter for MQSeries receives has no context properties. Therefore, BizTalk Adapter for MQSeries does not initialize the internal structures correctly.

↑ Back to the top


Resolution

Hotfix information

BizTalk Server 2006

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
You must have BizTalk Server 2006 installed before you apply this hotfix.
Restart requirement
You do not have to restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

BizTalk Server 2006, x86 version
File nameFile versionFile sizeDateTimePlatform
Microsoft.biztalk.adapter.mqs.dll3.5.1708.0107,56815-Sep-200710:15x86
Microsoft.biztalk.adapter.mqsadmin.dll3.5.1708.095,28815-Sep-200710:15x86
Mqsagent.dll3.5.1708.0183,29615-Sep-200710:15x86
BizTalk Server 2006, x64 version
File nameFile versionFile sizeDateTimePlatform
Mqsagent.dll3.5.1708.098,81615-Sep-200710:19x64
Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

BizTalk Server 2004

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
You must install the following software before you apply this hotfix:
  • BizTalk Server 2004
  • BizTalk Adapter for MQSeries
Restart requirement
You do not have to restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Microsoft.biztalk.adapter.mqs.dll2.0.452.0136,58415-Aug-200715:23x86
Microsoft.biztalk.adapter.mqs.interop.dll2.0.1.017,81615-Aug-200715:23x86
Microsoft.biztalk.adapter.mqsadmin.dll2.0.452.095,63215-Aug-200715:23x86
Mqsagent.dll2.0.452.0150,88015-Aug-200715:23x86
Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

↑ Back to the top


Keywords: kbautohotfix, kbbtsadapters, kbbiztalk2006presp1fix, kbhotfixserver, kbqfe, kbexpertiseinter, KB941494

↑ Back to the top

Article Info
Article ID : 941494
Revision : 4
Created on : 10/23/2007
Published on : 10/23/2007
Exists online : False
Views : 438