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Error message when you try to connect to a file server by using an alternative NetBIOS name in Windows Server 2003: "No network provider accepted the given network path"


Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows

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Symptoms

On a computer that is running Windows Server 2003, you receive the following error message when you try to connect to a file server by using an alternative NetBIOS name that is registered in Windows Internet Name Service (WINS):
No network provider accepted the given network path
This problem does not occur on a computer that is running Windows XP with Service Pack 2.

Note You can connect to the file server by using the fully qualified domain name (FQDN) of the file server or by using the IP address of the file server.

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Cause

This problem occurs because the computer does not send a NetBIOS adapter status request after the computer receives a negative session response from the file server. You expect the computer to send this request to obtain the list of NetBIOS names that are registered for the adapter.

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Workaround

To work around this problem, use one of the following to connect to the file server:
  • The FQDN of the file server
  • The IP address of the file server
  • The DNS alias of the file server

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

The following network trace is captured on a computer that is running Windows Server 2003:
<Client><File server>NbtSSNbtSS: SESSION REQUEST, Length = 68
<File server><Client>NbtSSNbtSS: NEGATIVE SESSION RESPONSE, Length = 1
<Client><File server>TCPTCP: Flags=....A..., SrcPort=1139, DstPort=NETBIOS Session Service(139), Len=0
<Client><File server>TCPTCP: Flags=F...A..., SrcPort=1139, DstPort=NETBIOS Session Service(139), Len=0
<File server><Client>TCPTCP: Flags=....A..., SrcPort=NETBIOS Session Service(139), DstPort=1139, Len=0
This network trace indicates that the computer does not send more requests after it receives a negative session response.

The following are the details of the negative session response:
+ Ethernet: Etype = Internet IP (IPv4)
+ Ipv4: Next Protocol = TCP, Packet ID = 718, Total IP Length = 45
+ Tcp: Flags=F..PA..., SrcPort=NETBIOS Session Service(139), DstPort=1139, Len=5, Seq=<number> - <number>, Ack=<number>, Win=<number>
- Nbtss: NEGATIVE SESSION RESPONSE, Length = 1
- NormalNbtSS:
PacketType: NEGATIVE SESSION RESPONSE, 131(0x83)
+ Flags: Add 0 to Length
Length: 1(0x1)
ErrorCode: Error: Called name not present. 130(0x82)
The following network trace is captured on a computer that is running Windows XP with Service Pack 2:
<Client><File server>NbtSSNbtSS: SESSION REQUEST, Length = 68
<File server><Client>NbtSSNbtSS: NEGATIVE SESSION RESPONSE, Length = 1
<Client><File server>TCPTCP: Flags=....A..., SrcPort=3737, DstPort=NETBIOS Session Service(139), Len=0
<Client><File server>NbtNsNbtNs: Query Request for * <0x00> Workstation Service
<File server><Client>NbtNsNbtNs: Query Response, Success for * <0x00> Workstation Service
...
<Client><File server>NbtSSNbtSS: SESSION REQUEST, Length = 68
<File server><Client>NbtSSNbtSS: POSITIVE SESSION RESPONSE, Length = 0
<Client><File server>SMBSMB: C; Negotiate, Dialect = PC NETWORK PROGRAM 1.0, LANMAN1.0, Windows for Workgroups 3.1a, LM1.2X002, LANMAN2.1, NT LM 0.12
<File server><Client>SMBSMB: R; Negotiate, Dialect is (#5)
This network trace indicates that the computer sends a request after the computer receives a negative session response. The request is to obtain the list of NetBIOS names that are registered for the adapter. This request resembles the following:
<Time> 0003FF82FBCF 0003FF86FBCF NBT NS: Query req. for *<00...(15)> C02WXN02WKS TESTSRV IP 
<Time> 0003FF86FBCF 0003FF82FBCF NBT NS: Query (Node Status) resp. for *<00...(15)>, Success TESTSRV C02WXN02WKS IP
NBT: Question Count = 0 (0x0)
NBT: Answer Count = 1 (0x1)
NBT: Name Service Count = 0 (0x0)
NBT: Additional Record Count = 0 (0x0)
NBT: Resource Record Name =*<00...(15)>
NBT: Resource Record Type = Node Status Request
NBT: Resource Record Class = Internet Class
NBT: Time To Live(Seconds) = 0 (0x0)
NBT: RDATA Length = 119 (0x77)
NBT: Number of Names = 4 (0x4)
NBT: ASCII Name = C02E3N02SRV 00
NBT: Resource Record Flags = 1024 (0x400)
NBT: ......0......... = Non-Permanent
NBT: .....1.......... = Active Name
NBT: ....0........... = Name is not in Conflict
NBT: ...0............ = Not Deregistering
NBT: .00............. = B Node
NBT: 0............... = Unique NetBIOS Name
NBT: ASCII Name = CORP2 00
NBT: Resource Record Flags = 33792 (0x8400)
NBT: ......0......... = Non-Permanent
NBT: .....1.......... = Active Name
NBT: ....0........... = Name is not in Conflict
NBT: ...0............ = Not Deregistering
NBT: .00............. = B Node
NBT: 1............... = Group NetBIOS Name
NBT: ASCII Name = CORP2 <1E>
NBT: Resource Record Flags = 33792 (0x8400)
NBT: ......0......... = Non-Permanent
NBT: .....1.......... = Active Name
NBT: ....0........... = Name is not in Conflict
NBT: ...0............ = Not Deregistering
NBT: .00............. = B Node
NBT: 1............... = Group NetBIOS Name
NBT: ASCII Name = C02E3N02SRV
NBT: Resource Record Flags = 1024 (0x400)
NBT: ......0......... = Non-Permanent
NBT: .....1.......... = Active Name
NBT: ....0........... = Name is not in Conflict
NBT: ...0............ = Not Deregistering
NBT: .00............. = B Node
NBT: 0............... = Unique NetBIOS Name

Steps to reproduce this problem

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
  1. Disable direct Server Message Block (SMB) hosting on the file server. This step makes sure that you connect to the file server only over the 139 port. To do this, set the SMBDeviceEnabled registry entry to 0 (zero). The SMBDeviceEnabled entry is in the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NetBT\Parameters
  2. Create a static unique record in WINS that has an alternative name that points to the IP address of the file server. Make sure that the DNS system has no entry that has the same name.
  3. Try to connect to file server by using the following path:
    \\AlternateName

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Keywords: kbtshoot, kberrmsg, kbexpertiseinter, kbprb, kb

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Article Info
Article ID : 940684
Revision : 3
Created on : 4/20/2018
Published on : 4/20/2018
Exists online : False
Views : 109