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FIX: Multiple lines of an IDOC record are not parsed correctly in BizTalk Adapter for mySAP Business Suite


View products that this article applies to.

Symptoms

When you use the Microsoft BizTalk Adapter for mySAP Business Suite to receive an intermediate document (IDOC) from an SAP system, BizTalk Adapter for mySAP Business Suite cannot run successfully when BizTalk Adapter for mySAP Business Suite parses the IDOC stream. Additionally, you receive the following error message:
Index out of bounds
At the same time, the SAP system receives the following error message:
Target Invocation failure
This problem occurs if an IDOC instance contains a text field that allows for multiple lines.

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Cause

This problem occurs because the SAP adapter parses the stream line by line. The SAP adapter returns an invalid IDOC if a record contains multiple lines.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have BizTalk Adapter for mySAP Business Suite or BizTalk 2004 or BizTalk 2006 installed to apply this hotfix.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
BizTalk Adapter v2.0 for mySAP Business Suite BTS04 SP1
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
sapreceiver.dll2.0.1020.070,66406-Dec-200712:01x86
BizTalk Adapter for mySAP Business Suite BTS2006
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
sapreceiver.dll2.0.1020.070,66406-Dec-200712:04x86
Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: KB940563, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter, kbautohotfix

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Article Info
Article ID : 940563
Revision : 2
Created on : 1/3/2008
Published on : 1/3/2008
Exists online : False
Views : 419