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FIX: On a Windows Server 2003-based computer, network traffic occurs when you run an unauthenticated DCOM client application to connect to a remote server


View products that this article applies to.

Symptoms

On a Windows Server 2003-based computer, you run an unauthenticated DCOM client application to connect to a remote server. When you do this, one or more of the following problems occur:
  • Network traffic occurs. Even though the application releases the interface or even though the application closes, network traffic still occurs.
  • If you enable the Audit logon event and the Audit logoff event, these events immediately fill the event log.
  • If the application calls a remote interface six minutes after the remote interface is obtained, you receive the following error message:
    RPC_E_DISCONNECTED (0x80010108) The object invoked has disconnected from its clients.

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Cause

This problem occurs because the Remote Procedure Call Server Service (RPCSS) on the Windows Server 2003-based computer impersonates the credentials of the process token of the application. However, the remote server cannot authenticate the credentials of the process token. Then, the RPCSS tries to connect to the server by using the Anonymous Logon account. However, the Anonymous Logon account does not have the Remote Access permission on the remote server. Therefore, the RPCSS pings the remote server repeatedly until you restart the Windows Server 2003-based computer.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Windows Server 2003 Service Pack 2 installed to apply this hotfix.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 Service Pack 2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Rpcss.dll5.2.3790.4120482,30420-Jul-200706:34x86
Windows Server 2003 Service Pack 2, Itanium-based systems
File nameFile versionFile sizeDateTimePlatform
Rpcss.dll5.2.3790.41201,047,04019-Jul-200716:15IA-64
Windows Server 2003 Service Pack 2, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Rpcss.dll5.2.3790.4120838,65619-Jul-200716:15x64

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Workaround

To work around this problem, use the DCOM Configuration tool (Dcomcnfg.exe) to grant the Remote Access permission to the Anonymous Logon account.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

The RPCSS implements the DCOM garbage collection mechanism for all Microsoft COM applications that run on the local computer. For more information about the DCOM garbage collection mechanism and about pinging, visit the following Microsoft Developer Network (MSDN) Web site: For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseinter, kbfix, kbqfe, kbHotfixServer, KB940466

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Article Info
Article ID : 940466
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 265